Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Anonymous Submitter - 2003-05-07
Last edited by bagder - 2003-12-05

FS#1326 - status bar disappears during recording

It reappears briefly every minute when time is updated.
When leaving the recording screen, it returns as
normal.

john.donahue@excite.com
JBR FM ver1.30j
Rockbox ver CVS-030507
ROM: 1.23
Mask: 0×0304 USB: pos
ATA: 0×200 PR: pos
Freq: 11.0592MHz

Closed by  bagder
2003-12-05 09:22
Reason for closing:  Fixed

I can confirm that this also occurs on my JBR FM 20 with
daily builds archos20030430.ajz thru archos20030512.ajz
and perhaps as early as archos20030422.ajz (don’t have em),
but does not occur with archos20030421.ajz and earlier.

[Hardware info]
ROM: 1.23
Mask: 0×0304 USB: positive
ATA: 0×200 PR: positive
Freq: 11.0592MHz

[Internal]
JBR-FM v2.1 (firmware 1.30i)
Micronas MAS 3587F B2 (2333 57 LKX)
Archos DCMP3J HD6437034R14X
SST MPF 39VF020 90-4C-WH
INsystem ISD300A1
MT 0044 4LC1M16E5-6Z (2Mbyte memory)
Hitachi DK23DA-20F

Anonymous Submitter commented on 2003-05-16 12:38

The Digest for Apr23/03 mentions a change log for status
bar updating. Maybe that fix caused the problem. The dates
on the problem builds seem to coincide.
john.donahue@excite.com

I managed to resolve this one by setting status_draw(true) in
recorder.c CVS-030521 around line 430 as per this patch:

@@ -430,7 +487,7 @@

                        global_settings.rec_quality);
               lcd_puts(0, 6, buf);

- status_draw(false);
+ status_draw(true); /* i like to see the
status */

               lcd_update();
           }
Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

Ok, here’s a clean patch for cvs-030521 (previously posted
patch was mangled with other patches sorry):
http://www.geog.ubc.ca/~kujala/cvs_20030521_bug_733896.diff Official rockbox developers, feel free to upload this patch.
-vincent.

Anonymous Submitter commented on 2003-05-25 01:16

Is status_draw(false) causing it to disappear or is it just
saying ‘dont bother rewriting an unchanged status’?

Is the cause instead line ~235 in status.c:
lcd_clearrect(0,0,LCD_WIDTH,8);
which is being executed even though status is unchanged?

JohnD

Project Manager
zagor commented on 2003-05-26 09:27

Fixed. Your patch was correct vkujala.

JohnD: The status bar area is only cleared when
force_redraw (or a few other conditions) are true.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing