Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Applications
  • Assigned To No-one
  • Operating System Sansa Clip Zip
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Roman Artiukhin - 2021-03-04
Last edited by Solomon Peachy - 2021-03-14

FS#13269 - Image Viewer is broken in recent builds

All images give me “Data abort at 30 FSR 0×8…” error or displayed as black screen.

Found on daily build made on 210205 (and same error on latest)

Attached “cover.jpg” works properly in 3.15 release

Closed by  Solomon Peachy
2021-03-14 17:11
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in eb9f05f, confirmed working by reporter.

Willliam W commented on 2021-03-05 02:18

Need more info:

What is your config like?
Are you playing music at the time? (filetype?)
size of images?
upload of a failing image greatly appreciated

Roman Artiukhin commented on 2021-03-05 03:12

It's broken for all images I tried. Though I only tried for cover.jpg images placed in folders with music. No matter music is playing or not. Attached example with image and config.cfg to task description

Roman Artiukhin commented on 2021-03-05 03:41

Huh.. Strange. Data abort is no longer reproducible for me .. But all images are shown as black screen instead.

And another example with different error. Maybe not related. This one gives "unsupported -4" and it's also not shown on WPS.

   Cover.jpg (27.9 KiB)
Willliam W commented on 2021-03-10 13:41

this (27kb image) is actually a JFIF file its a bitmap in jpeg clothing
https://en.wikipedia.org/wiki/JPEG_File_Interchange_Format

W10 by chance?
https://www.techsupportalert.com/content/how-stop-windows-10-saving-jpgs-jfifs.htm

the cover art above (1.42 mb image) is also JFIF

Roman Artiukhin commented on 2021-03-10 14:08

Yes W10. But all images were downloaded elsewhere - I didn't save them myself..

I've just installed version 3.15 and Cover art is displayed properly. 27 kb image still gives me "unsupported -4" error.

Willliam W commented on 2021-03-10 14:35

Oops my mistake I was thinking EXIF I guess JFIF is not the issue

I'm testing on a ClipZip as well and I got a data abort on one of the files one of the times I loaded it

so I'll call this confirmed but IDK what the root cause is yet

Willliam W commented on 2021-03-10 15:34

The 27Kb image is not a supported

the decoder says
0xC2: /* SOF Huff - Progressive DCT*/
/* other DCT model than baseline not implemented */

https://github.com/Rockbox/rockbox/blob/master/apps/plugins/imageviewer/jpeg/jpeg_decoder.c#L551

See the format here:
http://www.vip.sugovica.hu/Sardi/kepnezo/JPEG%20File%20Layout%20and%20Format.htm

Willliam W commented on 2021-03-11 03:49

Think I got the data abort fixed

https://gerrit.rockbox.org/r/c/rockbox/+/3211

Note:
If using greyscale it appears you need dithering to get it to work?

Roman Artiukhin commented on 2021-03-11 04:59

Yes it works now. Tested on my Sansa Clip Zip and Sansa Clip+. Thank you!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing