Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System xDuoo X3ii
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.15
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by murmel - 2021-03-14
Last edited by speachy - 2021-04-09

FS#13272 - xDuoo X3ii: sound setting for max-vol-limit is ignored

testing version: 714f7a21da on: xDuoo X3ii

settings - sound settings - maximum volume limit

  1. silly low limit: -1020db (which is not a bug)
  2. activating any value is completely ignored. regardless playing or restarting playback. even silencing sound via VOL- down to minimum and regain after using VOL+ high-end-maximum power is reached and a defined max-vol-limit is ignored.

BTW: thank you for the work - until now - well done

linklokal :)

Closed by  speachy
2021-04-09 14:36
Reason for closing:  Fixed
Additional comments about closing:  

Works for me now, please re-open if it's not okay.

update:

settings -1020dB is interpreted as -102.0dB. this works!

step-size of 1/10dB

Admin

This is a deceptively nasty problem – the volume limit setting sort of piggybacks on the volume setting but isn't aware of the many nuances involved – such as the fact that a lot of hardware doesn't use 1dB steps.

So this has been broken for quite a while on many of our hardware targets.. I'm still trying to figure out how best to fix this.

Admin

A fix for this was committed in 213d372c92, and I confirmed it works on the X3ii.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing