Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category USB operation
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Medium
  • Priority Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Rockbox
Opened by ThePhxRises - 2021-03-15
Last edited by speachy - 2021-05-17

FS#13273 - USB Mass Storage Mode Does Not Work With Flash Adapter

As of the daily build from March 12th (and continuing to the 14th’s) attempting to transfer files over USB Mass Storage mode while using a common flash adapter for an iPod Video results in a halted transfer after a few seconds. It also results in Rockbox being stuck in USB mode until it’s rebooted, even after it is unplugged. I am not sure if this behavior existed in daily builds prior to the 12th, but it definitely exists in the 3.15 Release build. I have been told that this issue also affects builds on the iPod Classic. As far as I can tell, I believe Power Management would need to be disabled entirely when these flash adapters are detected (or by a manual toggle in settings) in order to allow proper USB file transfers.

UPDATE: After testing a build from the 11th (before the newest ATA changes), the same problem seems to persist. It may be important to note that I am using an unbranded “green board” and Digigear branded CF adapter, rather than the corresponding iFlash brand adapter. However this shouldn’t change Rockbox’s perception of them as they both show Power Management and Advanced Power Management as “unsupported” in Disk Info. The DMA mode is however listed as UDMA 2, whereas I was under the impression that these flash adapters functioned better under UDMA 1 and that an earlier commit had addressed this.

Closed by  speachy
2021-05-17 15:31
Reason for closing:  Fixed
Additional comments about closing:  

Now all is good in the universe.

Admin

I'm trying to understand how some folks seem to report no problems and others still have issues.

Can you generate an identify info dump and send it over to me please?

(under rockbox info / debug)

Also, are you using a USB2.0 port or a USB 3.0 port?

Admin

Oh, since it also failed with builds older than the 11th, the problem is not due to power saving modes..

Please try this custom build:

http://www.shaftnet.org/~pizza/rb-video.zip

This is a one-off build that backs off to UDMA1; please try it and see if that makes things more stable. Let me know the rockbox info it reports!

Attached is the identify info. I have been testing by transferring an around 150mb file to the root of the drive. On the previous build, it stops mere seconds in. On this one-off build it copies much faster, and stopped with about 40mb remaining, at which point the iPod froze for a second and disconnected and reconnected itself from Windows, which stopped the transfer with an error. Unplugging the iPod after this still results in Rockbox being stuck in USB mode until reboot.

Oh, and I have been testing with 2.0 ports, but the issue seems to occur on 3.0 ones as well.

Interestingly, further testing seems to show this issue (or at least a superficially similar one) happening in the iPod's own dedicated disk mode.

However, file transfers inside the actual original firmware itself are not only much faster than either rockbox or disk mode, but don't stall or fail no matter how much I copy.

After further testing and some really strange behavior, I've gotten the transfer to complete successfully once. Every previous and subsequent attempt has gotten cut off early, with various behavior from disconnecting from Windows and refusing to reconnect properly until Windows is rebooted, to a simple freeze and Rockbox crashing on disconnect with the error:

*PANIC*
mount: 0
pc:00066440 sp:000f1a38
bt end

Reads from the storage over USB seem to be fine, writes not so much. Odd.

Admin

https://gerrit.rockbox.org/r/c/rockbox/+/3352

This patch has had some promising results so far.

Still getting freezes during large transfers, then after unplugging the iPod, it still gets stuck in USB mode and then crashes with

*PANIC*
mount: 0
pc:00066598 sp:000f2cb8
bt end

or similar.

Read operations are totally fine, write operations not so much.

Admin

Please try again with current daily builds; by all reports the final version of g#3552 solved the corruption other folks were having.

Can confirm, all is good for me in regard to file transfers on the latest daily! Thanks a ton for your work on it, it's so good to see it working now.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing