Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System xDuoo X3ii
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by iMpig - 2021-03-31
Last edited by Solomon Peachy - 2021-04-01

FS#13281 - Problems playing the first song after player turned on

Hi,
for a few daily builds now I’ve been having problems playing the very first song after the player is turned on. There are some exceptions to this outlined below.

Today I tested it more thoroughly on a 058a9ec945 (xDuoo x3ii) build.
The files/songs are the same I had on my player for a while now and had no problems with before.

Full description:

The player won’t play the very first song chosen after the power on. I’ll refer to it as the “first song” from here on.

Exception 1: The above is only true if the first song ~played is NOT form the same directory as the one played last - before the reboot/previous session. So it is not a problem for resuming playback within the same directory.

Exception 2: If in the previous session (before the boot) no song was played (there is nothing to resume with “resume playback”) ANY file will play fine as the first song.

Exception 3: Please note that the problem exists for about 90% files I tried (mp3s and flacs) but I have found some (mp3s only, so far) that play always (as the first song). I have not identified anything special about these files, but it seems related to their encoding since usually all the files within the same album work - likely being encoded in the same manner (guessing). Like stated at the top - my files are likely all fine/not corrupt and I had no such problems on older (~month) builds.

So to continue…

When I try to “play” the first song, the metadata of the song title is wrong - it displays the title of the previously played file (the last one BEFORE the reboot), from a different directory. The artist/album title metadata is displayed correctly (for the correct file that’s trying to be played) but the cover art is not loaded. There is no sound or indication of file being played (time elapsed).

Play/pause doesn’t help - nothing changes besides the play/pause icon.

Next/ffwd doesn’t help - it displays the next song title metadata within the directory of the previously played file (the last one BEFORE the reboot) while the album and artist seem to be displayed correctly. No sound.

If the player is shut down at this point (no song was successfully played within the session) the “resume playback” on the next reboot will have no memory of files being tried/played.

Workaround:

One doesn’t need to reboot the player in order to continue with listening, all you need to do is go “back” to the “file browser” and select a file, even if it’s the same one as just tried (first song). Everything (with all files) will be normal from there on - within the same session. This is another indication, I think, that my “test” files are okay and not the cause for the problem.

While the problem description above may sound like an edge case that rarely happens - it’s really frequent and easily recreated, well at least in my experience.

I have my suspicion (just based on the description) that the fix called “3251 : Fix  FS#13278 : error message when playing a song with Rockbox for the very first time” might have something to do with it. Please don’t put much weight on this as I’m just guessing here based on the title - my apologies to the author in advance.

Thank you and best regards, iMpig

Closed by  Solomon Peachy
2021-04-01 10:15
Reason for closing:  Fixed
Additional comments about closing:  

Should be fixed in 674c07d654

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing