Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System All players
  • Severity Medium
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Next release
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Rockbox
Opened by kutubyebye - 2021-06-10
Last edited by speachy - 2021-07-25

FS#13299 - Cannot play some music file. Ipod classic 120gb Rockbox. One of the music attached.

I installed Rockbox on my ipod classic 120gb recently.

Very good app but does not play some music that I have.

Attached is one of the music that does not play in my rockbox.

Please help.

Based on mp3tag. It’s mpeg1-layer1 type. Not sure if it is because of this.

It does not play using both the file and the database function.

Tried in both 3.15 release and also the dev release.

The music can play in VLC, MPC-HC and Windows Media Player on my PC without any problem.

Closed by  speachy
2021-07-25 00:09
Reason for closing:  Fixed
Additional comments about closing:  

thanks for te-resting!

Can anyone help me to confirm if the problem is not on my end only?

Admin

okay, it's failing to parse these files.

I think what's going on is that this file is not only vbr, but variable sample rate too – and I think that variable sample rate is what's screwing things up here, as we require two consecutive headers with the same parameters to consider this to be a "valid" file.

Admin

Do you know what encoded these files? I've never actually seen a variable sample rate file in the wild before.

Admin

Ok, there are two independent bugs in play; the first related purely to parsing the file – the file has supurfluous padding inbetween its mpeg frame blocks, and that confused the metadata parser. My proposed fix is here: https://gerrit.rockbox.org/r/c/rockbox/+/3478

However, even with that bug fixes, the file will not play back. This I suspect is due to it being a variable bitrate layer 1 file, which I'm told that libmad (or at least the version we've been using) does not support. But also troubling is that variable sample rate thing I mentioned earlier; I don't believe rockbox can handle that either.

I'll keep digging, but I think the most expedient solution for you would be to re-encode these files, either by using a different mp3 encoder, or a different format (ogg, opus, mp4/aac, etc) entirely. My question about the origin of these files is still pertinent though…

No, I do not know what encoded it. I downloaded the file from a music streaming site.

Other files obtained the same way works with no problem.

The file is just this way from the music site server.

I'm not very tech/programming savvy. But maybe a short term solution would just be to trick the Rockbox to try playing the file anyway? or force play it? with a yes/no warning, maybe.

Well, I hope Rockbox will update with the function to play these kind of files in the future.

How did you manage to find out that it was vbr and variable sample rate? All along I thought it was 128kbps. Is there a guide how to identify it? I would like to learn how to do it.

Thanks for the confirmation. I'm glad the problem has been identified.

Admin

There is debug code in the mp3 parser that reports the parameters of each high-level "frame" in the file, including bitrate and sample rate.

I've committed the change I referenced earlier; the file can now be parsed properly, but it can't be played back – I'll have to wade into the codec code to see what's going wrong there.

bahus commented on 2021-06-13 17:04
Do you know what encoded these files?

Not sure if it's really true but TagScanner identifies encoder as lame 3.99.

Thanks for working on it. Looks like you are making progress. I hope you will able to find the solution soon.

VLC and MPC-HC seems to just detect it as constant bitrate 128kbs and 44.1kHz even if the actual data is variable.

Well, I'll leave it to you since you are the expert. Never give up :D

I'll keep checking this post for updates.

Admin

Turns out I was chasing a red herring. The latest dev build seems to play back this file without any issues, hopefully not introducing any regressions in the process.

Let me know, thanks.

This means I should be able to play the file if I reinstalled the dev build today?

Finally updated my rockbox.
Current version of dev build is able to play music.
Problem is solved.
Thank You Very Much.

Thank You Speachy.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing