Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System xDuoo X3ii
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by salty-horse - 2021-08-21
Last edited by speachy - 2021-11-03

FS#13305 - xDuoo X3ii: Paused playback will resume when unplugging headphones

Using recent build from 2021-08-16 c302c157d5dd1c32ff47e1ba774c310a3f1f7dc4.

Maybe this affects all players, but I only checked mine.

If playback is paused, and I unplug the headphones, then playback will resume automatically.
This doesn’t make sense, as the device has no audio output.

The opposite behavior DOES make sense: If playback is active, and I unplug the headphones, then it pauses.

Closed by  speachy
2021-11-03 17:19
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in revision 5e663f0420

This feature already exists in the settings.

My ""pause on headphones unplug"" was off, which shouldn't perform any pause/resume.

The cause of the problem is something else. Perhaps a an imagined signal from the headphones button when plugging/unplugging.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing