Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Settings
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by dconrad - 2022-12-07
Last edited by Bilgus - 2022-12-09

FS#13378 - Main Menu Reordering and Maintain a List of Recent Bookmarks both broken

Only tested on build a1e4385a (haven’t bisected yet)

Main menu reordering works, until you reboot the device or plug in USB and then unplug it. Then you will only have Resume Playback and Settings in your main menu.

Workaround: delete the “root menu order:” line from the config file, the default ordering comes back ok.

To reproduce:

  1. Go to the main_menu_config.rock plugin, move some stuff around (I did Resume Playback to the very top) and save it.
  2. Note that it worked correctly on the main menu
  3. Reboot the device
  4. main menu broken

Secondarily (and actually possibly more importantly?) Recent Bookmarks doesn’t seem to stay either.

To reproduce:

  1. Enable Maintain a List of Recent Bookmarks = One per playlist
  2. Note that the entry exists in the main menu
  3. Reboot
  4. entry gone
Closed by  Bilgus
2022-12-09 02:32
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407 Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

https://git.rockbox.org/c git/rockbox.git/commit/?id=3555e84a7a

just as a note: apparently a89f279fd4 is ok on the recent bookmark side

Both appear to be ok as of f3b522cac

And the culprit for both appears to be 90bc76956

Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

I have checked it the Problem is the Patch
https://git.rockbox.org/cgit/rockbox.git/commit/?id=90bc76956c1a6cd29a9120a4bafa3bbdfe39f428

I have localy removed it and the Probleme is gone.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing