Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System Eros Q / K
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by dconrad - 2022-12-07
Last edited by Bilgus - 2022-12-10

FS#13379 - Backlight exemption while advanced keylock exemption also enabled no longer works

This one is kind of specific… also may depend on if the device in question has volume in list. Pretty sure this worked as expected before, but I’m not 100%. I haven’t bisected yet.

build a1e4385a, tested on eros q native.

  1. Enable advanced keylock, exempt volume.
  2. Enable Backlight Exemptions, Exempt Volume
  3. Lock the player on the main menu, let the backlight go off.
  4. The volume buttons still wake up the display.
  5. Go to the WPS
  6. Lock the player and let the backlight go off again.
  7. The volume buttons do not wake up the display, as expected.
Closed by  Bilgus
2022-12-10 07:52
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407 Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

https://gerrit.rockbox.or g/r/c/rockbox/+/4899

bug still present in f3b522

still present in d06cf3ac

still present in 773fa78

still present in 8b522b8973

still present in 5fdd491

still present in 498988, circa oct. 21, I'm guessing it's not a new regression

present in 4d01168b9b as of 05-30, yeah I'm gonna say it's a preexisting bug

Admin
did you try before May 23, 2021
https://github.com/Rockbox/rockbox/commit/10d199f9d5bf85136211c0811e29679787343375
Admin
Nope its been this way since the beginning it is predicated on CONTEXT_FM/CONTEXT_WPS
https://github.com/Rockbox/rockbox/blob/master/apps/action.c#L1004

the issue is that we have extra processing to do so maybe just check the volume buttons
Admin
https://gerrit.rockbox.org/r/c/rockbox/+/4899

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing