Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System xDuoo X3ii
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by impig - 2024-03-29
Last edited by speachy - 2024-04-11

FS#13410 - Crash pressing "back" button from the paused player

With my xduoox3ii I started experiencing frequent crashes lately when trying to get back to file browser from a paused player.

* file type doesn’t seem to matter - crashed with mp3s and flacs
* it crashed on files with artwork and without it
* voice announce menus on/off doesn’t matter (I tested this because I recently updated voice files)

To reproduce:

Open a music DIR and play a file, then:
- skip track or two ahead
- skip a track or two back
- then press pause
- AND (this is the trigger) press the cancel/back* button
- FREEZE (see attached image for error msg, always the same, player restarts after keypress)

* To identify which button I mean with “cancel/back”: It is the button that brings you back to file browser.
On my player (xduoox3ii) it has the “return” arrow icon and is located left of the play button. It is not the “previous song |«” button. If you hold it for a second it brings up the “context menu”. What’s the button called in Rockbox context?

Affected versions:
52e22b253d-240329
19f21a2b3f-240329
53e7176196-240324
c00dff157c-240324 (!) ←- perhaps changes made here are to blame

NOT affected:
ae01ea7fd9-240223
8bdf08cd2d-240330 ←- possibly issue fixed


Closed by  speachy
2024-04-11 11:57
Reason for closing:  Fixed
impig commented on 2024-03-29 15:36

I forgot to mention that reproduce instructions are not exact and you need to try several times, with some "randomness" in key presses, but should be happening within 10 tries.

bahus commented on 2024-03-29 15:38

https://www.rockbox.org/tracker/task/13049#comment44606

You said that
> rockbox-xduoox3ii-20240307.zip seems to be stable.`

Is it true? (you didn't mention it in current description) Next daily build with changes is 53e7176196-240324. So it contains some breaking changes:
https://download.rockbox.org/daily/changelogs/changes-20240324.html

impig commented on 2024-03-29 15:40

Crashed with c00dff157c-240324 so it should be caused by changes in this build.

I'll go back to ae01ea7fd9-240223 now to test more, if it's really stable.

impig commented on 2024-03-29 15:44

@bahus yeah "20240307" is the "ae01ea7fd9-240223" reported stable one. I'm using rockbox-info.txt as a reference

bahus commented on 2024-03-29 15:48

Well there is a chance it's already fixed in latesd dev build:
https://build.rockbox.org/data/rockbox-xduoox3ii.zip

As some related fix has been committed recently:
https://git.rockbox.org/cgit/rockbox.git/commit/?id=52e22b253d

impig commented on 2024-03-29 15:49

Will be trying the latest dev build you linked, thanks.

impig commented on 2024-03-29 15:57

No luck with the latest build https://build.rockbox.org/data/rockbox-xduoox3ii.zip 52e22b253d-240329 has crashed too.

impig commented on 2024-04-06 07:00

In some short time testing 8bdf08cd2d-240330 seems to resolve the issue. Will report back if I can reproduce it at a later time.

impig commented on 2024-04-11 11:01

Looks like the new builds are stable and this task can be closed. Thank you for the support.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing