Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To
    speachy
  • Operating System xDuoo X3ii
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by impig - 2024-04-06
Last edited by speachy - 2024-04-07

FS#13411 - No .rockbox directory found error with the latest build

I tried the latest build 76a9a524c0-240404 for the xduoox3ii but when Rockbox booted it informed me that there was a ~”no .rockbox directory”. The message disappears quickly so I’m not sure that’s the exact wording. After that there is no “skin/theme” present and a file browser is shown with what looks like linux file system.

I shut down the player and reinserted the SD card, tried again. Same thing. I verified on my computer that there was a .rockbox dir on the card. Everything seemed fine in terms of files.

I then reverted back to ae01ea7fd9-240223
With the old build everything is back to normal.

Same behavior also on:
3714288f7a-240403

No problem on:
8bdf08cd2d-240330

PS: I didn’t test al the versions in between 8bdf08cd2d-240330 and 3714288f7a-240403 since it’s only a few days of changes.

Closed by  speachy
2024-04-07 20:20
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

Confirmed fixed by d1f14c7b.

Will be part of tonight's build.

Admin

I can confirm it’s busted. Pretty sure I know what is causing this, but I need to research the best way to fix it.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing