Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category FM Tuner
  • Assigned To
    Bilgus
  • Operating System Sansa Clip+
  • Severity High
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by deyke - 2024-05-01
Last edited by Bilgus - 2024-05-06

FS#13420 - Sansa Clip+ - selecting FM Tuner hangs player - needs hard reset

Sansa Clip+ - selecting FM Tuner hangs player - needs hard reset. This happens with rockbox-sansaclipplus-20240501.zip

Closed by  Bilgus
2024-05-06 14:34
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

out of range values to the tuner hangs the device

I think when the region changes the values could be out of bounds and cause a hang,
fixed in https://gerrit.rockbox.or g/r/c/rockbox/+/5706

Admin

I can't reproduce this, try renaming the .rockbox dir and try a clean install
make sure you aren't using any themes until you verify this works

otherwise perhaps hardware failure or some difference I'm not seeing

Will leave this open till I have a chance to see if theres anyway to make it more robust

deyke commented on 2024-05-02 05:44

You are correct, completely replacing the .rockbox dir with the dev build fixes the FM Tuner problem, but looses all my customizations. Before I was only adding the dev build files to my existing .rockbox dir.

Admin

well I'd suspect a theme then.

try to narrow it down to 1 or two things that cause it, If I can find it I can probably fix it

thanks, will

deyke commented on 2024-05-02 17:39

Would it help if I would attach the old .rockbox directory I had before I copied the dev build over it? It is 23M in size so to big for a single attachment. Or would the list of filenames help?

Admin

If you can't reproduce it from a fresh build then its probably a bad nvram file or bad config
you can try deleting the nvram files from a copy of the old build (not your backup)
and see if that helps

if you still can't repro other than your specific backup then the .rockbox folder will have to to get it smaller delete the whole plugins folder that should knock off 20MB

deyke commented on 2024-05-03 15:09

Please don't worry about it anymore, it was probably just a bad config, although I do not understand how it got bad, and why it did not cause errors with the old build. Since everything is working now for me, please close the bug.

Thanks!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing