Rockbox

Tasklist

FS#1345 - *Panic* rec fls: -144

Attached to Project: Rockbox
Opened by Anonymous Submitter - Monday, 12 May 2003, 09:40 GMT
Last edited by Daniel Stenberg (bagder) - Friday, 05 December 2003, 09:47 GMT
Task Type Bugs
Category Drivers
Status Closed
Assigned To No-one
Operating System
Severity High
Priority Urgent
Reported Version Release 2.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After Record:
*Panic* rec fls: -144
This task depends upon

Closed by  Daniel Stenberg (bagder)
Friday, 05 December 2003, 09:47 GMT
Reason for closing:  Fixed
Comment by Anonymous Submitter - Wednesday, 14 May 2003, 17:23 GMT

I'm also experiencing this. I've used the recording feature
successfully quite a lot but all of a sudden, it keeps failing.

I'm recording on analog line-in, with gain boosted 3.0db, with AC
power plugged in, on quality settings 3,4,and 5.
Comment by Björn Stenberg (zagor) - Wednesday, 14 May 2003, 17:32 GMT

This is most likely due to a bad fat file system on the disk. Our
fat code does not handle file system errors very gracefully, I'm
afraid.
Comment by Anonymous Submitter - Thursday, 15 May 2003, 00:21 GMT

Any suggested workaround for now?
Comment by Björn Stenberg (zagor) - Thursday, 15 May 2003, 07:36 GMT

Nothing short of a reformat, I'm afraid.
Comment by Björn Stenberg (zagor) - Thursday, 15 May 2003, 08:06 GMT

Nothing short of a reformat, I'm afraid.
Comment by Anonymous Submitter - Tuesday, 27 May 2003, 22:28 GMT

same with my jukebox recorder 20, all stored files are displayed
in a weird way and cannot be opened or copied in windows
explorer, so i have to retransfere all the mp3s after formating
the drive ;|
Comment by Anonymous Submitter - Wednesday, 11 June 2003, 19:18 GMT

Ok. I reformatted. It happens less often, now, but it still
happens.
Comment by Linus Nielsen Feltzing (linusnielsen) - Thursday, 12 June 2003, 09:18 GMT

Can you describe your procedures a little? I mean, is your
drive almost full? Did you defragment it? How did you format
it, and with what parameters/options? How do you transfer
your recordings to the PC?

I need all the details I can get, so I can repeat the
problem on my device.

Linus
Comment by Anonymous Submitter - Sunday, 22 June 2003, 21:10 GMT

I'm getting this too. Doesn't record. I don't see anywhere to enter a
filename for recordings anyway.

fishbuys@attbi.com
Comment by Linus Nielsen Feltzing (linusnielsen) - Sunday, 22 June 2003, 23:31 GMT

This problem should be fixed in the latest daily build.
Please try that. And regarding the filename, you don't enter
a filename in Rockbox, it is autogenerated.
Comment by Anonymous Submitter - Tuesday, 24 June 2003, 01:09 GMT

I found and installed the 2.0 release on my Jukebox
Recorder20 today (Rom 1.28). I tried recording via the mic.
Record started up ok. WhenI hit the [off] button to stop
recording , I got the *Panic* rec fls: -144 and the device
locked up - forcing a power-cycle reboot.

I downloaded and installed the latest daily build
(archos20030623.ajz). Again, record seems to start ok. When
I hit [off] a mesaage box quickly appears and disappears
stating: "Disk Full...". (I currently have 16gb free on my disk.)
Also, a .mp3 file of size 0bytes was written in the root
directory, even though I was in a different directory when I
started the record! Any fixes , workarounds, etc?

For now, I'm going back to the Archos OS since I depend on
my unit for live recording talks, etc.

I really hope these bugs get worked out. Your OS makes the
Archos recorder powerful. (Stomps the IPOD..)

Thx,
dyah2k@yahoo.com


Comment by Linus Nielsen Feltzing (linusnielsen) - Thursday, 14 August 2003, 23:40 GMT

Since bug #762051 is confirmed to be fixed, this one should
also be considered fixed.

Loading...