FS#1380 - Font file does not always work in cfg file

Attached to Project: Rockbox
Opened by Bruce Weston (brucewston) - Tuesday, 20 May 2003, 22:33 GMT
Last edited by Linus Nielsen Feltzing (linusnielsen) - Sunday, 11 April 2004, 00:11 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Release 2.0
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


I have a file called car.cfg with one font file listed in it,
and a file called headphones.cfg with another font file
listed in it - both font files are in the .rockbox folder.

The problem is that after I ran the car.cfg file, the font
changed to what I had listed in that configuration file,
but then when I toggle to running the headphones.cfg
file, it seems to pay no attention to the font file listed
in that configuration.

After I recently stopped one long playlist I was
listening to, the situation reversed itself. In other
words, upon running the headphones.cfg file, the font
actually switch to the specified one in that file for the
first time ever, and then running the car.cfg file would
not switch the font back to the font file defined in

I figured that each time a cfg file was run it would
change the font to the file specified (if one is
specified), but it does not seem to always work that
way. Additionally I was hoping that by putting the font
files that I run from inside the cfg files inside of
the .rockbox folder, that I could gain the functionality
that the latest choice of font would retain itself after
reboot much the same way as many of the other
settings in a cfg file do.

Not sure if I have identified a bug, or just a limitation
by design here.

Thank you.
Keep up the great work!
Bruce Weston
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Sunday, 11 April 2004, 00:11 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Logged In: YES

No reply. I'm closing this report.
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 01 March 2004, 18:48 GMT

Remember that you need the full path info to the font in the
.cfg file:

font: /.rockbox/fonts/atadore.fnt

I can't reproduce the bug on my box, using the 2004-03-01
daily build .
Comment by Linus Nielsen Feltzing (linusnielsen) - Sunday, 11 April 2004, 00:11 GMT

No reply. I'm closing this report.