FS#1477 - recycled bin mystery

Attached to Project: Rockbox
Opened by Anonymous Submitter - Friday, 27 June 2003, 05:24 GMT
Last edited by Björn Stenberg (zagor) - Wednesday, 23 July 2003, 23:58 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Release 2.0
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


This is probably painfully obvious, but the solution eludes
me and it is most frustrating. After installing Rockbox
V. 2.0 on my Archos Jukebox Recorder 20 (OS rom is V.
1.28, model JBR20101), I was really digging all of the
subtleties of your firmware. But when I tried to delete
the old mp3's that had been on there, so I could load all
fresh tracks to enjoy with the superior interface, the old
files were just moved to a recycled folder on the mp3
player, not deleted. To add to the frustration, the
several hundred files were renamed sequentially - rec1,
rec2... (or something like that). Those renamed files
would play just fine, but I couldn't tell what was what
from the filenames. After several fruitless experiments -
nothing too drastic, mind you - I have somehow ended
up with just 2 files (showing) in the recycle bin:
desktop.ini, and info2. What the heck? And the
recycle folder does NOT appear on my monitor when I
dock to my desktop computer! (But when I tried to
create a new recycled folder while docked, as an
experiment, it was not allowed bc it said the folder
already exists. Yet a 'search' on the same screen said
no such folder or file was present...) Meanwhile,
the 'info' option shows that the 10+ gig of files that I
was originally trying to delete are still there, with only
8.3 of 18.6 gig of hard drive space free. (Also, please,
why only 18.6, if it is supposed to be 20 gig?) I really
want to straighten this out, and to get the optimal use
out of this monster. Please help! THANK YOU. My
email is Any advice is most
welcome. (Perhaps I am not the only user to have this
This task depends upon

Closed by  Björn Stenberg (zagor)
Wednesday, 23 July 2003, 23:58 GMT
Reason for closing:  Invalid
Comment by Mike Holden (mikeholden) - Friday, 27 June 2003, 07:40 GMT

First off, this is not a Rockbox bug, so should not have been
reported here.

You don't mention it, but I assume you are using Windows.
This is standard Windows functionality. With the Archos
plugged into your desktop machine, you need to empty your
recycle bin. This will also clear the recycle bin on your
Archos. There will be an option on your desktop system to
hide certain system files and folders, which is why you can't
see the recycled folder. If you change that setting, you will
then be able to see the recycled folder as well.

20 gig is the unformatted size of the disk. When you format
the disk, you lose some space to create the filesystem.
Comment by Rick C Myers (rcmcse) - Sunday, 20 July 2003, 03:56 GMT

i have the same problem with dir buffer full with the recycle
Comment by Björn Stenberg (zagor) - Wednesday, 23 July 2003, 23:11 GMT

This is not a rockbox bug.