FS#1478 - Recorder 20 mp3 record problems. Rkbx 2.0 & latest daily...

Attached to Project: Rockbox
Opened by don (drockbox1) - Friday, 27 June 2003, 19:35 GMT
Last edited by Daniel Stenberg (bagder) - Friday, 05 December 2003, 09:44 GMT
Task Type Bugs
Category Recording
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Release 2.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I found and installed the 2.0 release on my Jukebox
Recorder20 today (Rom 1.28). I tried recording via the
Record started up ok. WhenI hit the [off] button to stop
recording , I got the *Panic* rec fls: -144 and the
locked up - forcing a power-cycle reboot.

I downloaded and installed the latest daily build
(archos20030623.ajz). Again, record seems to start ok.
I hit [off] a mesaage box quickly appears and disappears
stating: "Disk Full...". (I currently have 16gb free
on my disk.)
Also, a .mp3 file of size 0bytes was written in the root
directory, even though I was in a different directory
when I
started the record! Any fixes , workarounds, etc?

For now, I'm going back to the Archos OS since I depend
my unit for live recording talks, etc.

I really hope these bugs get worked out. Your OS makes
Archos recorder powerful. (Stomps the IPOD..)

This task depends upon

Closed by  Daniel Stenberg (bagder)
Friday, 05 December 2003, 09:44 GMT
Reason for closing:  Fixed
Comment by Linus Nielsen Feltzing (linusnielsen) - Saturday, 28 June 2003, 00:52 GMT

I really wish I could make this error happen on my own
jukebox, then I could find the bug easily. I'm completely in
the dark here.

BTW, Rockbox always saves the recorded files in the root,
regardless of where you are with the file browser.
Comment by Anonymous Submitter - Tuesday, 08 July 2003, 14:59 GMT

I downloaded the daily build and installed it yesterday.
Recording now works beautifully. Man, what a great
improvement over the Archos software! Kudos to you guys!!!