FS#1518 - digital out does not work

Attached to Project: Rockbox
Opened by Anonymous Submitter - Sunday, 13 July 2003, 02:13 GMT
Last edited by Linus Nielsen Feltzing (linusnielsen) - Monday, 01 November 2004, 10:33 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Release 2.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


The digital out does not work when I run the archos
with the rockbox OS (version 2.0, 2003-04-15).
However, it works fine with the default OS.

Here is the requested debug info:

rom: 1.28
mask: 0x0302
usb: positive
ata: 0x200
pr: positive
freq: 11.0592MHz

William Bonnell
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Monday, 01 November 2004, 10:33 GMT
Reason for closing:  Fixed
Comment by Anonymous Submitter - Sunday, 13 July 2003, 02:15 GMT

Almost forget to mention, this is the Jukebox Recorder 20
Comment by Linus Nielsen Feltzing (linusnielsen) - Friday, 09 April 2004, 23:24 GMT

Is there any difference with Rockbox 2.2?
Comment by Anonymous Submitter - Saturday, 22 May 2004, 21:58 GMT

I'm using Jukebox Recorder 20 as well and my Sp/DIF doesn't
work with RockBox 2.2.

Work's fine when I load the Archos Firmware.

Rom: 1.28
Mask: 0x0302
USB: Positive
ATA: 0x200 Master
PR: positive
Comment by LsToRm (spanias) - Sunday, 30 May 2004, 12:46 GMT

I have the same problem.
Debug info is the same.
I use Jukebox Recorder 20.
Comment by Paul van der Heu (paulheu) - Sunday, 30 May 2004, 12:59 GMT

I use digital out (and in) all the time without a problem.
Comment by Anonymous Submitter - Tuesday, 22 June 2004, 04:28 GMT

I have rockbox 2.2 and I have had no luck with the digital out
on my Archos recorder 20. I would like to use this output but
it doesn't work, maybe i should try to reload the default

Comment by Anonymous Submitter - Friday, 24 September 2004, 04:08 GMT

I have the same problem with a Jukebox Recorder 20. I
cannot use the S/PDIF when RockBox 2.2 is loaded. Sure
would like for this to work since I hook it up to the main
stereo for parties and such and like the playlists.

I have gone back to the built in OS version 1.28.

Cheers and keep up the good work.
Comment by Linus Nielsen Feltzing (linusnielsen) - Friday, 24 September 2004, 05:13 GMT

This is a hard one for me to fix, since it works perfectly
on my recorder 20. Could you please try the latest daily
build to see if that works?
Comment by LsToRm (spanias) - Friday, 24 September 2004, 09:01 GMT

I have the latest build on my Jukebox but I'll have to get
back to you if it works cause I'm out of the country right now.
Comment by Anonymous Submitter - Monday, 27 September 2004, 00:01 GMT

I tried the latest build (CVS 040926) and still no joy. I did not
flash the eprom I just use the file in the root. Could that be a
difference? The other idea is that there is something in the
CFG file that might be inadvertantly stopping the S/PDIF. I did
a "reset settings" but still no joy.

Jukebox Recorder 20
USB 2.0
ROM 1.28

Cheers........Val from New Mexico
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 05 October 2004, 20:07 GMT

This is fixed in CVS. Thanks for reporting.