FS#1557 - Possible fade out bug

Attached to Project: Rockbox
Opened by Ofir Carny (whitemouse) - Monday, 28 July 2003, 13:45 GMT
Last edited by Daniel Stenberg (bagder) - Friday, 13 May 2005, 22:18 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



When listening to a long file (1500min+), after pressing
stop, I get a what appears to be a normal fade out, but
it end in an abrupt rise in volume (to the normal level)
for what I think is about 100ms.

I don't think the problem is related to the file length, but
I didn't try other files. The file is usually played based on
the resume feature.
This task depends upon

Closed by  Jens Arnold (amiconn)
Friday, 13 May 2005, 00:17 GMT
Reason for closing:  Fixed
Additional comments about closing:  Logged In: YES

Fixed in cvs
Comment by Ofir Carny (whitemouse) - Wednesday, 30 July 2003, 13:27 GMT

It is definetly unrelated to the resume feature, it seems that
the volume is cranked back up before an audio buffer is
completely empty.
Comment by Jens Arnold (amiconn) - Friday, 13 May 2005, 00:17 GMT

Fixed in cvs
Comment by Mike Holden (mikeholden) - Friday, 13 May 2005, 09:08 GMT

I thought we left fixed issues as "open/fixed" status, until the
next full release comes along, rather than "closed/fixed"???
Comment by Jens Arnold (amiconn) - Friday, 13 May 2005, 22:14 GMT

Björn told me that this policy is no longer applicable. Bugs
should now be closed immediately after fixing them. So I did.
Comment by Daniel Stenberg (bagder) - Friday, 13 May 2005, 22:18 GMT

The reason for that is simply that the amount of open
entries that we otherwise need to walk through and close at
a later time becomes quite overwhelming (I've done it
several times, it takes hours of manual clicking).

It is better if we all take care of whatever we can now and
make sure to get them out of our face when they're fixed.
One by one.