Rockbox

Tasklist

FS#1586 - Refuses to play playlists not generated by system

Attached to Project: Rockbox
Opened by Anonymous Submitter - Wednesday, 06 August 2003, 05:04 GMT
Last edited by Daniel Stenberg (bagder) - Friday, 05 December 2003, 09:23 GMT
Task Type Bugs
Category Playlists
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Release 2.0
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

When I attempt to play a playlist all I get is the
message "End of Song List", and nothing plays. Playlists
are created in MusicMatch JukeBox and these same
playlists work fine in the original Archos firmware. I have
reloaded all the playlists and also reloaded the Rockbox
OS. At another user's suggestion I tried the current daily
build, with the same results.

Whilst troubleshooting I used the "create playlist"
function of the Rockbox OS to create a root playlist and
a playlist for a folder and they play fine, but none of my
other play lists works at all, always giving me the same
message "End of song list"

Configuration Info:
Jukebox FM Recorder
Rom 1.30j
Rockbox Ver 2.0 (Also tested with 8/6/03 daily build, ver
CVS-030806)
Playlists generated by MusicMatch Jukebox version
7.20.0166Archos
One of the playlists generated by Music Match that
doesn't work is attached to this report.

cory@frii.com
This task depends upon

Closed by  Daniel Stenberg (bagder)
Friday, 05 December 2003, 09:23 GMT
Reason for closing:  Rejected
Comment by Björn Stenberg (zagor) - Wednesday, 06 August 2003, 08:06 GMT

This playlist contains C:\Documents and Settings\Cindy
Casciato\My Documents\Cory's Folder\Music\Blur\The Great
Escape\Blur - Stereotypes.mp3

I guess it's safe to assume you don't have this path on your
archos. Where is this mp3 file stored on your archos?
Comment by Anonymous Submitter - Wednesday, 06 August 2003, 19:40 GMT

No, that path is the path to the files located on my PCs HD,
as generated by Music Match. My FMJB directory structure
has two ditrectories of root, one for playlists (called Playlists)
and one for MP3 files (called MusicFM). The playlist directory
has two subdirs, an Album directory and a Custom directory.
The Music FM folder is divided into subdirectories by artist,
then by album. So the Blur - The Great Escape playlist I
uploaded is located in \Playlists\Albums while the mp3 files are
located in \MusicFM\Blur\The Great Escape.

I tried moving some playlists to the root directory and the
MUsicFM parent directory, thinking perhaps the playlist could
only look into the same dir structure, but the results were the
same: End of Song List message every time I try to play it.

cory@frii.com
Comment by Björn Stenberg (zagor) - Wednesday, 06 August 2003, 20:29 GMT

So on your archos, the mp3 file is located in:

\MusicFM\Blur\The Great Escape\

...while your playlist claims it's in:

C:\Documents and Settings\Cindy
Casciato\My Documents\Cory's Folder\Music\Blur\The
Great
Escape\

The archos path is not even a subset of the playlist path! I
have no idea what Archos does to find the file, but rockbox
generally trusts the contents of the playlist.

In short: Your playlist contains the wrong path. The file is
not located where the playlist says it is, and thus Rockbox
can't find it. This is not a bug, it's just bad input.
Comment by Anonymous Submitter - Wednesday, 06 August 2003, 20:53 GMT

Interesting...when the Archos accesses a playlist, it does
what appears to be a search for the files. Does the Rockbox
not do this? How tolerant is the playlist functionality of the
Rockbox software? I'm just looking for a workaround, since I
am not going to stop storing my MP3s on my PC or start
generating all my playlists in the Rockbox... Any advice or
insight you can offer into how the Rockbox handles playlists is
appreciated.

PS You might consider adding some sort of search
functionality to the Rockbox for this reason.

Loading...