FS#1641 - different USB disblay when plugged in off or on

Attached to Project: Rockbox
Opened by Anonymous Submitter - Wednesday, 20 August 2003, 14:23 GMT
Last edited by Daniel Stenberg (bagder) - Wednesday, 17 March 2004, 08:06 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Hello, when I plug in my archos fm recorder to the usb
port when it is shut off, it shows the charging function
in the top left corner. When I plug it in while it is on, it
just shows the amount of battery power left and doesn't
appear to be charging. Also, while plugged to usb, it
doesn't actually seem to be charging. Is there a way I
can tell if I have a powered port? I have a fairly new pc
with usb 2.0.
This task depends upon

Closed by  Daniel Stenberg (bagder)
Wednesday, 17 March 2004, 08:06 GMT
Reason for closing:  Fixed
Comment by Mike Holden (mikeholden) - Saturday, 23 August 2003, 13:34 GMT

This is not a Bug report.

With Rockbox running and the USB cable UNplugged, go to the
Debug->View Battery screen, then press DOWN once, so you get
a screen that shows Power status.

This screen will show the external power, which should be
around zero (probably something like 0.02 V). Now plug in
the USB cable and see if the value changes. Even if the
battery is fully charged, this value will increase by some

If you want to discuss this further, go to the Rockbox
mailing list.
Comment by Anonymous Submitter - Sunday, 23 November 2003, 11:37 GMT

yes mikeholden i'll shall go to the mailing list
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 01 March 2004, 18:40 GMT

This is fixed in CVS.