FS#1702 - *PANIC* -31 Broken Archos?

Attached to Project: Rockbox
Opened by Anonymous Submitter - Wednesday, 24 September 2003, 04:42 GMT
Last edited by Linus Nielsen Feltzing (linusnielsen) - Monday, 12 July 2004, 05:21 GMT
Task Type Bugs
Category Drivers
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


After booting with flash rom (used to work fine) I get an
error msg -31 I ran a continuous debug until nothing
worked. After powered on died after a second. recharger
didn't work either, usb couldn't be hooked up. I thought
it might be a bad charge so i drained the batt. and
hoped for the best. tried a recharge and it tweaks out
like a kid with terrets! ON off! ON off! Won't even power
on. SOS! Send help.
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Monday, 12 July 2004, 05:21 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Logged In: YES

No reply. I'm closing this report.
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 24 September 2003, 05:17 GMT

Yes, that is a quirk with the flashed Recorder versions, at
least the earlier ones. You will need to charge the
batteries in an external battery charger, then everything
will be back to normal again.
Comment by Anonymous Submitter - Saturday, 27 September 2003, 02:32 GMT

I have almost the same problem with the Studio 20 it will only
work with charger plugged in and dies immediatly on startup if
Comment by Anonymous Submitter - Saturday, 27 September 2003, 15:11 GMT

Yes guys, I have just had the same problem: I flashed the
BIOS a few months ago and everything worked fine (except
some issues with shutting down with the charger plugged
showing me ATA error and blocking the unit until re-plugged).

The matter is that I stored my Jukebox in a box and didn´t
use it for several weeks so I guess batteries charge drained
completely. Today, when I tried to start it again it didn´t
work, so I plugged the charger... the same problem: it began
a loop of ON-OFFs every 0.5 seconds and the Hard Disk
making some tiny noise.
I was shocked! Was my Jukebox Dead!!!??? But, if it worked
Happily I had some charged batteries stored, I put them in
and switched on, crossed my fingers, hold my breath... and It
worked fine again. Thanks God!

So, I think that the problem is that if the batteries are
completely discharged the Jukebox/Rockbox is unable to start
and charge, EVEN IF THE CHARGER IS PLUGGED!!! You need
to have some charge in the batteries to start it all.

I don´t know if it is a Hardware or Sofrtware matter, but I
hope this can help somebody.


Comment by Anonymous Submitter - Tuesday, 28 October 2003, 10:28 GMT

Same problem...
ATA error -31
I think it might be too a bad charge.

After powered, some noise in archos *tac*tac* then Off.
With F1 + On, archos goes off after 3-4 sec.

When I plug it with charger, debugger begins : "master
0x200" , battery 4.22... then Off
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 28 October 2003, 10:33 GMT

As I said, try to charge the batteries in an external
charger. We will fix this issue as soon as we can.
Comment by Cornu (ocornu) - Thursday, 25 December 2003, 18:09 GMT

Any news to solve this problem ?
Comment by Anonymous Submitter - Friday, 26 December 2003, 20:42 GMT

yea i have pretty much the same problem, and charged the
batteries with an external battey charger. No luck with
that...still busted... any other solution?
Comment by Karen Holdt (ti-ana) - Wednesday, 31 December 2003, 18:41 GMT

I had the same problem: my Jukebox (flashed with rockbox
2.1) didn't charge. I hope, someone will find a solution for
this problem.

I have a workaround: start your Jukebox by holding F1 and
the "on"-button. Now your Jukebox should start with the
original archos firmware and there you should be able to
charge your box without pulling out the batteries.
Comment by Linus Nielsen Feltzing (linusnielsen) - Thursday, 11 March 2004, 07:21 GMT

This issue is supposes to be fixed in the daily builds.
However, you need to reflash the boot loader.
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 12 July 2004, 05:21 GMT

No reply. I'm closing this report.