Rockbox

Tasklist

FS#1778 - Crash when recording from disconnected Digital In

Attached to Project: Rockbox
Opened by Paul van der Heu (paulheu) - Monday, 03 November 2003, 17:27 GMT
Last edited by Daniel Stenberg (bagder) - Friday, 05 December 2003, 09:43 GMT
Task Type Bugs
Category Recording
Status Closed
Assigned To Linus Nielsen Feltzing (linusnielsen)
Operating System
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details


Start recording
Wait few secs
hit OFF

I04:IllInstr at C050F360

---

Start recording
Wait few secs
hit PLAY
wait few secs
hit OFF
red led comes on and Rockbox freezes

This task depends upon

Closed by  Daniel Stenberg (bagder)
Friday, 05 December 2003, 09:43 GMT
Reason for closing:  Fixed
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 03 November 2003, 18:07 GMT

Do you have any tips on how to reproduce it? I can't make it
happen on my jukebox.

Any special settings?
Comment by Paul van der Heu (paulheu) - Monday, 03 November 2003, 19:16 GMT

I always record using digital in, it's with this setting the bug
shows up. However At the time I had no digital signal coming
into the archos, so that might be why it fails. Still it should
not crash because of that.. so do the above action with
digital source selected, but no source connected..

I tried it with mic and line in and there is no problem then..
The only difference is that with digital source nothing is
recorded when there is no signal, with analogue source an
empty file is recorded when no signal is present..(but that is
normal behaviour.)
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 03 November 2003, 19:21 GMT

Ah. Now we're getting somewhere. I'll try to fix that as
soon as possible.
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 03 November 2003, 20:06 GMT

This is fixed in CVS.
Comment by Paul van der Heu (paulheu) - Monday, 03 November 2003, 20:47 GMT

Well, almost...

Recording a single file with digital in now works, but do this:

1. hit record
2. wait a few secs
3. hit play
4. (red light and disc activity, counter resets)
5. wait a few secs
6. hit play
7. (no red licht, ni disc activity, counter resets)
8. hit OFF
9. Rockbox freezes

If you hit off at 6 all goes well.

As before all this with digital in selected and no connection on
the digital in
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 03 November 2003, 21:06 GMT

Ah, forgot about that case. I have now fixed that too.

Loading...