Rockbox

Tasklist

FS#181 - Fails to play some tracks

Attached to Project: Rockbox
Opened by Anonymous Submitter - Thursday, 29 August 2002, 13:44 GMT
Last edited by Daniel Stenberg (bagder) - Friday, 11 October 2002, 06:29 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Release 1.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have JBR20 with on-board firmware 1.24.

If I use RockBox 1.3, some files will not play -
instead, I get a screen that looks like:
____________________
| |
| |
| |
| 1024kbit 1024KHz |
|__________________ _|

No other info on screen, but that text appears in the
"correct" place. The information is of course wrong -
the encoding was 128kbit and 44.1KHz, if I remember
correctly.

I know I have some files which may have incorrect
timing information (the Archos firmware (I am using
1.27c) plays these correctly, but displays a time which
is an integer multiple of the actual time, and counts
down at double or triple speed to compensate. Winamp
2.8 plays them quite happily with the correct file info
so I don't know what the problem is.). I don't know if
this is related.

Other than that, RockBox is something I can see myself
moving to - probably on the next major release. Keep up
the good work.

Regards,

Stephen Johnson
stephen@athene.freeserve.co.uk
This task depends upon

Closed by  Daniel Stenberg (bagder)
Friday, 11 October 2002, 06:29 GMT
Reason for closing:  Fixed
Comment by Björn Stenberg (zagor) - Thursday, 29 August 2002, 17:43 GMT

Please provide one of the malfunctioning files so we can
debug this problem.
Comment by Martin Borus (bchow) - Friday, 30 August 2002, 08:01 GMT


Just a comment:

On my JBR20 with on-board firmware 1.28 I get this screen
sometimes when playing some very long files (3 hours and
more). It goes away after 1-2 seconds and then the file plays
correctly.
Comment by Anonymous Submitter - Friday, 30 August 2002, 08:21 GMT

You can download one of the problem files
from

http://www.thylacine.pwp.blueyonder.co.uk/files/rockbox/01_The_One_I_Am.mp3

This
plays fine under Archos's firmware 1.27c and Winamp on the PC.
Comment by Anonymous Submitter - Friday, 30 August 2002, 08:21 GMT

You can download one of the problem files
from

http://www.thylacine.pwp.blueyonder.co.uk/files/rockbox/01_The_One_I_Am.mp3

This
plays fine under Archos's firmware 1.27c and Winamp on the PC.
Comment by Björn Stenberg (zagor) - Sunday, 01 September 2002, 16:01 GMT

That track plays just fine with Rockbox too.
Comment by Linus Nielsen Feltzing (linusnielsen) - Friday, 06 September 2002, 06:06 GMT

Zagor, when you receive a bug report on the 1.3 release, you must try to
reproduce it on the 1.3 as well.
You tried to play the file on the latest
daily build and assumed that the guy had it all wrong. This bug is the same
as bug #601730, and was already fixed in CVS when you tried to play this
file. Just telling the guy that "it plays just fine with Rockbox too" was not all
that polite, IMHO.
Anyway, this bug is fixed in CVS.
Comment by Anonymous Submitter - Friday, 06 September 2002, 06:44 GMT

Thanks.

Stephen
Comment by Björn Stenberg (zagor) - Friday, 06 September 2002, 10:23 GMT

My bad. Apologies.
Comment by Anonymous Submitter - Friday, 06 September 2002, 10:42 GMT

No harm done - it's good for me to doubt my sanity
occasionally :-)

I've just installed the most recent daily build and it works
fine.

Thanks,

Stephen

Loading...