FS#188 - MP3 files end prematurely

Attached to Project: Rockbox
Opened by John Peel (mower7) - Friday, 30 August 2002, 18:55 GMT
Last edited by Daniel Stenberg (bagder) - Friday, 11 October 2002, 06:30 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To Björn Stenberg (zagor)
Operating System
Severity Low
Priority Normal
Reported Version Release 1.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I have a AJBR6 (now with an IBM 20Gig)
It came with version 1.17i in the ROM but
currently load 1.27d.

I have a problem that some of my mp3 files
play fine, but then end prematurely.
For example a 5 min song will play the
first 1.5 min of the song, and then move
directly to the next song as if the first
song had ended. I assume that this happens
when the buffer is refreshed. This has happened
on mulitple mp3s on my AJBR. The songs play
fine on the original firmware, and of course
on winamp.

I also wondered if there was something screwed
up with the file in the filesystem or something
so I moved the file around to see if it would
magically "fix" it, but it did not.

The point at which it "ends" is very repeatable.

This happens on both version 1.2 and 1.3 of
the Rockbox firmware.

At this point it looks like my AT&T broadband
server is acting screwy, so I could email my
example file to someone, or maybe put it on
an ftp/http site later...

This task depends upon

Closed by  Daniel Stenberg (bagder)
Friday, 11 October 2002, 06:30 GMT
Reason for closing:  Fixed
Comment by Anonymous Submitter - Friday, 30 August 2002, 21:14 GMT

It also happens on my AJB6k (4.56) with Rockbox 1.3.
Comment by Linus Nielsen Feltzing (linusnielsen) - Friday, 30 August 2002, 22:17 GMT

Please try the latest daily build and see if the problem is gone. Please
report back in either case. Thank you.
Comment by John Peel (mower7) - Friday, 30 August 2002, 22:25 GMT

I downloaded archos20020830.ajz for the recorder and
it still does it.

Comment by Björn Stenberg (zagor) - Saturday, 31 August 2002, 11:40 GMT

This is most likely the same bug as 578026 "Track does not
recover after disk error".
Comment by Anonymous Submitter - Sunday, 01 September 2002, 20:23 GMT

Same problem with original hd.
JBR6G (1.17i). No Problems with rockbox 1.2 though...
Comment by Anonymous Submitter - Monday, 02 September 2002, 21:36 GMT

I tried build from 2002-09-01 and the "jumping" always occurs.

after replaying an MP3 which was cuted short while playing, it played
entirely, so it doesn't seem to be specific to some files.

Also when
the problem occurs, no ID3 is read for the MP3 which is played after the
Comment by John Peel (mower7) - Tuesday, 03 September 2002, 19:07 GMT

Well the problem seems to have gone away on that
song, so I'm inclined to agree with you that it is
releated to a Disk read error problem. All versions
seem to now work on this particular song. Setting the
Disk Spindown setting to 4-5s seems to have helped, but
now I can run it all the way down to 2s and it still
works ? makes me wonder if there was an unitialized
variable floating around that setting that field changed ?
who knows ? that is just a guess :)

Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 03 September 2002, 19:43 GMT

We fixed a serious ATA driver bug yesterday that had to do with the
spindown timer. That explains why it now works with a 2s timeout.
Comment by Anonymous Submitter - Saturday, 07 September 2002, 15:48 GMT

I have a similar pattern: After several hours playback the
AJB6 (with IBM 30 Gig)
stops playing back certain mp3s. Replacing the archos.mod
with another one
fixes the problem for the next few hours playback. Problem
occurs for
the original Archos archos.mod, Rockbox 1.2, 1.3 and recent
CVS builds (tried
it up to 2002-09-06.
Even via USB the mounted partition (linux) will produce slow
reads or even
read errors on these files (everything fine after archos.mod
Switching on/off doesn't help, taking batteries out doesn't
help either.
Comment by Björn Stenberg (zagor) - Friday, 13 September 2002, 10:32 GMT

This is fixed in CVS.