FS#1929 - Error Accessing Playlist Control File

Attached to Project: Rockbox
Opened by sundar raman (cybertoast) - Friday, 16 January 2004, 20:42 GMT
Last edited by Linus Nielsen Feltzing (linusnielsen) - Saturday, 13 March 2004, 22:07 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Release 2.1
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


My system info:
Buffer: 1.652MB
30% 4h 2m
Disk: 18.6GB
Free: 2.3GB
Rockbox 2.1

Playing some files (still investigating exactly which,
since it does not appear to be easily reproducible),
player will sometimes just halts when playing the
track. Here's what i've noticed so far:
- red LED turns on when error occurs
- track time does not increment when the error occurs
- Clicking Vol +/- does nothing [no response, no change]
- Clicking track +/- [<</>>] does nothing
- Pressing 'stop' button brings me to what should be
a playlist (sometimes after 3-5 seconds), but the
playlist is blank. None of the navigation buttons (<<,
>>, V, ^) do anything. Menu button gives me "Resume?
PLAY = Yes Any Other = No". F1, F2, F3 bring up
appropriate windows. Play (>||) button brings up
message "Error accessing playlist control file".

The only way to bring the player out of this state is
to reboot - by press STOP for few seconds.

Upon reboot, player gives me option to resume. If I
select 'Yes', track is played back from the point of
the error for some time (seems to be inconsistent, but
generally less than 10 minutes), then again stops
playing. Often the error occurs multiple tracks later.

When the error occurs the second time, and I am taken
back to the blank playlist, even Play (>||) stops
functioning - i.e., no response except backlight on/off.

Upon rebooting again, I do not get a choice for
resuming play. Instead I'm brought back to the root

Playing the same track that caused the error previously
does not cause a repetition of the problem.

I have not tried with a recent nightly build yet -
that's the next plan :-)
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Saturday, 13 March 2004, 22:07 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Logged In: YES

Sounds like a Red LED Death to me. Duplicate of #622799.
Comment by Linus Nielsen Feltzing (linusnielsen) - Saturday, 13 March 2004, 22:07 GMT

Sounds like a Red LED Death to me. Duplicate of #622799.