FS#1945 - Reduced Battery run time

Attached to Project: Rockbox
Opened by Anonymous Submitter - Tuesday, 20 January 2004, 13:28 GMT
Last edited by Linus Nielsen Feltzing (linusnielsen) - Friday, 05 November 2004, 07:07 GMT
Task Type Bugs
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


ARchos JukeBox recorder 20, upgraded to RockBox 2.1.

Battery run time is now halved, used to get 8-10 hours,
now I get <5 hours per charge, probably nearer 3 hours.
Also, it now takes a long time to recharge the jukebox.

Any FAQs on this pending a fix?

Does the fact that the backlight stays on while charging
affect the time taken to charge the batteries, if so any
way to switch that off?

All help appreciated.
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Friday, 05 November 2004, 07:07 GMT
Reason for closing:  Works For Me
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 20 January 2004, 13:37 GMT

Try setting General Settings->System->Disk Poweroff to "yes"
and see if the situation changes.
Comment by Björn Stenberg (zagor) - Tuesday, 20 January 2004, 14:12 GMT

If you plug in power AFTER you boot up Rockbox, the backlight
turns off after your normal configured timeout.

As for run time, i get 10+ hours with daily builds on my Rec20.
Have you tested going back to an old version, or the archos
firmware, to verify your suspicions that it is firmware related?
Comment by Anonymous Submitter - Tuesday, 17 February 2004, 14:51 GMT

Experienced similar on FM recorder 20 after approx 10 months
use. It turns out that the second battery in the pack was no
longer making a clean connection to the contact. I bent the
pin forward and regained my sanity.
Comment by Lucas B. (facted) - Tuesday, 24 February 2004, 16:09 GMT

I definately have the same problem happening to me. I don't
think this should be thrown aside simply because it can't be
reproduced by whoever checks the bugs. I currently have:
power off = yes, disk spindown = 3 s and backlight = 2
seconds and I'm getting considerably less battery life. I think
people should seriously look at this bug.
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 24 February 2004, 22:43 GMT

Well, since none of the developer's devices have this
problem, we can't figure out what's wrong. If it was a
simple bug, everyone would have this problem.

First of all, try to figure out if changing the Disk
Poweroff setting changes the situation in any way. Then
compare with earlier versions of Rockbox, and also with the
original firmware. Then we can move on to see if there is a
way to remedy this.
Comment by Lucas B. (facted) - Tuesday, 24 February 2004, 23:14 GMT

Linus: I have disk poweroff set to "on". I just ran my player
and got about 2:30-2:45 hrs versus 5 or 6 hours before with
1.27d archos firmware. I have an archos recorder 20 (the old
school ones) with niMh batteries. I bought the unit in the
summer of 2002 so I guess the batteries are getting a little
old. I just bought some 2200 mhA and i'm goign to replace
those as soon as I get them. In the meantime, what else can
I look at?

Also, one question: my buffer ram says it's only 1.56mb. is
that normal? Perhaps that has something to do with the lower
battery life?
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 24 February 2004, 23:17 GMT

The 1.56Mb buffer size shouldn't matter that much. How is
your "Max Files in dir browser" and "Max playlist size"
settings? You should keep them as low as possible to
maximize the buffer size.
Comment by Lucas B. (facted) - Tuesday, 24 February 2004, 23:24 GMT

I had both of those settings on their maximums. I have taken
both down to their minimums and we'll see what happens.
How much of a difference can that make? I wasn't using the
playlist at all and the directories I was in had maybe 5/6 files
max. Let me konw. If you'd like to move this e-mail, my
address is
Comment by Björn Stenberg (zagor) - Thursday, 26 February 2004, 09:58 GMT

I still have not seen anyone verify that going back the Archos
firmware or an earlier Rockbox build gives better run time.

That is ABSOLUTELY REQUIRED, since that is the only thing
that will prove this is a software problem.

Please help us help you.
Comment by Lucas B. (facted) - Tuesday, 02 March 2004, 02:16 GMT

As a programmer, I completely understand the need to
replicate the problem. I thought it was solved with the two
settings mentioned below being moved to their mins., but it

I recently bought 2200 mhA batteries and have fully charged
them and I still get a drop of 2-3 battery # indicators PER
SONG and these songs are ripped at 128 (not at 192 for

With all of this in mind, I am doing a test playing one album
for one hour from my fully charged unit with both the rockbox
release and the archos 1.27d release. I will hopefully post my
results later tonight or tomorrow. Hopefully that will help
identify if we really have a problem or not. I will also post my
procedure in that post. Enough for now...
Comment by Lucas B. (facted) - Tuesday, 02 March 2004, 05:34 GMT

So, I did exactly what I said I would do and what zagor
recommended: I went back to the archos firmware and
compared battery life. What I found is ASTOUNDING.

I played one album (on repeat) for 45 minutes with the
batteries fully charged using a daily build from 3 or 4 days
ago and the archos 1.27d firmware.

The results:

Battery %

rockbox archos
Initial: 100 100
15 min: 92 *
30 min: 88 *
45 min: 85 100

To get the numerical results for the archos firmware, i quickly
loaded (unplugged), the usb and renamed the firmware file
and read it off the rockbox firmware.

Gentlemen, I REALLY do not think you can overlook this
problem any longer. I had all the correct settings set: Disk
timeout on, anti-skip to 0, max files in a playlist to 1000, max
files in a folder to 100, led set to 2 seconds...I don't know
what else to do.

Please give me some feedback. I am more than willing to test
this problem for you. I would like to note that there was some
hard disk activity throughout playing the songs (which were
all 128). the red activity light would turn on perhaps 2-3
times per song (not sure if that's normal or not).

Remember, these are NEW 2200 mHA batteries. According to
the rockbox results, these batteries would only last about
300 minutes or 5 hours.

I will be posting this to the newsgroup to in order to get
some more feedback, but please let me know what can be
done about this! thanks.

Comment by Anonymous Submitter - Wednesday, 24 March 2004, 08:20 GMT

I was having the same probs with my old archos firmware on
my jukebox 10, got some new batteries and the new rock box
and my batteries last a full day @ work now, where before
they were down to a 3 hr life max. I saw the prvs comments
about charging while hooked up to usb, Archos firmware had
a prob with this it seemes, a few times I had charged all night
while hooked up to sharing software
Comment by Anonymous Submitter - Thursday, 29 April 2004, 20:29 GMT

I get this two. After three to four hours my FM Jukebox
starts cutting out during songs. This used to start
happening at about 30 now it can happen at 60, which is
reached very quickly.

Comment by shahar markovitch (m_shahar) - Tuesday, 01 June 2004, 11:16 GMT

I use my work Archos allot...
I use to had Rockbox ver. 2.0, now I moved to Rockbox ver
2.2 and I flashed my ROM with it.
Now my run time is reduced to 50% from what it used to be.
In addition, the archos doesn't play songs when the battery
is 20% full (this used to happen only on ~9% on rockbox 2.0).
So I belevie it's something to do with the newer versions of
rockbox, maybe even because of flashing (???).

Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 01 June 2004, 11:27 GMT

Can you verify that you get longer runtime if you revert to
the 2.0 version?
Comment by shahar markovitch (m_shahar) - Thursday, 24 June 2004, 09:53 GMT

After the 2.2 version can't play any more files (battary
capacity is 22%)...
I switched to the 2.0 version (using loading rolo)
and got some ~30 minutes more of playing time,
until the battary indication showed %9...

this also works if I switch to the Archos firmware (1.27d).

So I can definitely say that the problem is not in 2.0.