Rockbox

Tasklist

FS#1953 - Flash LED when waiting to record

Attached to Project: Rockbox
Opened by Jerry (vanbargw) - Thursday, 22 January 2004, 02:31 GMT
Last edited by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 22 June 2004, 10:58 GMT
Task Type Patches
Category
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Added an invert_led() function to the led.c utility.
This inverts the sense of the led() function. It is
most useful for flashing the LED without otherwise
affecting the LED's use.

Added code to the recorder.c function to blink the LED
while waiting to record so those of us who are rather
forgetful remember to start recording :-). This also
turns on the LED while recording so there is highly
visible feedback to less tuned in users.

By using the invert_led() function, disk accesses blink
the LED off (instead of on) while recording, allowing
the user to still see when disk accesses are happening.
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Tuesday, 22 June 2004, 10:58 GMT
Reason for closing:  Accepted
Additional comments about closing:  Logged In: YES
user_id=259137

Thanks a lot. I have now committed this patch.
Comment by Björn Stenberg (zagor) - Thursday, 22 January 2004, 08:34 GMT

I'm not sure I think it's a good idea to mix in new meanings
to the LED. People are pretty used to having it as a
harddisk activity indicator and some will probably be
confused if we start flashing it for various other reasons
too.
Comment by Philipp Pertermann (langhaarrocker) - Tuesday, 03 February 2004, 14:12 GMT

As far as the recorder is concerned I think that the use of
the leds should be extended too. But I'd prefer something
like this:
green on: unit is turned on
green blinks: disk activity
red off: no recording
red blinks: ready to record
red on: recording
Zagor: Most people wouldn't realize the change as they don't
record at all. But for those who do record it would be
really great to use the red led as recording indicator
because you can see that from the distance. I frequently
keep running around the practice room just to verify that
the thing is recording. Displaying the disk activity is a
mere comfort feature that doesn't provide _useful_ info.

Phil
Comment by Philipp Pertermann (langhaarrocker) - Tuesday, 03 February 2004, 14:25 GMT

As far as the recorder is concerned I think that the use of
the leds should be extended too. But I'd prefer something
like this:
green on: unit is turned on
green blinks: disk activity
red off: no recording
red blinks: ready to record
red on: recording
Zagor: Most people wouldn't realize the change as they don't
record at all. But for those who do record it would be
really great to use the red led as recording indicator
because you can see that from the distance. I frequently
keep running around the practice room just to verify that
the thing is recording. Displaying the disk activity is a
mere comfort feature that doesn't provide _useful_ info.

Phil
Comment by Björn Stenberg (zagor) - Tuesday, 03 February 2004, 14:36 GMT

We can't blink the green led. It's hardwired to power.
Comment by Jerry (vanbargw) - Wednesday, 04 February 2004, 01:04 GMT

OK, _this_ one works as intended (I think :-). In the
previous patch, I turned the LED off when recording rather
than turning it on (really stupid mistake). Incidentally,
the original firmware turns the red LED on when recording,
so this behavior is the same as the original firmware. I
missed that behavior because it gave good feedback that the
recording was happening.

Note that this _inverts_ the LED so hard drive activity is
shown by blinking the LED OFF instead of ON (again, same as
the original firmware).

The enhancement (Rockbox always has to be one better ;-) is
to flash the LED when waiting to start recording. I find
this to be very intuitive and a good reminder.

gvb
Comment by Anonymous Submitter - Tuesday, 09 March 2004, 16:57 GMT

sagor your dumb.
This is for ppl who record only,
and not for dumb ass noobs like you

When you do a lot of recording(ie multi-traking)
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 22 June 2004, 10:58 GMT

Thanks a lot. I have now committed this patch.

Loading...