FS#1963 - Crash when powered on from Archos charge mode

Attached to Project: Rockbox
Opened by P. V. G. (petesimon) - Sunday, 25 January 2004, 21:35 GMT
Last edited by Daniel Stenberg (bagder) - Wednesday, 09 March 2005, 10:34 GMT
Task Type Bugs
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


This information was recorded on: 01-25-2004

My username and email: petesimon,

Archos model info:
JBR FM (recorder)
Ver 20GB
P/N 300131
S/N (ask me via email)
Archos original firmware version: 1.30j

Rockbox HW Info:
ROM: 1.23
Mask: 0x0304
USB: positive
ATA: 0x200, master
PR: negative
Flash: M=BF D=D6
ROM CRC: 0x222F V1

Rockbox version:
CVS-040125 daily build

Description of problem:
I prefer to hold the F1 key and plugin the charger
connector so that the original Archos firmware boots up
and displays the charge mode status. When Rockbox is
in firmware and I press ON during this charge, Rockbox
crashes and shows "ATA error: -31 Press ON to debug".
Some debug information is continuously changing.

Here is "ON to debug" info:
PADR: 537F
AN0: 0(variable) AN4: 0(variable)
AN1: 3FF AN5: 00(variable)
AN2: 0(variable) AN6: 1(variable)
AN3: 3FF AN7: 3FF
BATT: 3.3 v -1%
ATA: master, 0x200

While this debug was shown I press STOP button and
saw "*PANIC* ATA error -31".
Also, see this bug report:
This task depends upon

Closed by  Daniel Stenberg (bagder)
Wednesday, 09 March 2005, 10:34 GMT
Reason for closing:  Fixed
Comment by Linus Nielsen Feltzing (linusnielsen) - Thursday, 25 November 2004, 06:35 GMT

This is fixed in CVS. Thanks for reporting.