Rockbox

Tasklist

FS#1967 - Dir Buffer is Full! error message

Attached to Project: Rockbox
Opened by Anonymous Submitter - Wednesday, 28 January 2004, 01:59 GMT
Last edited by Daniel Stenberg (bagder) - Wednesday, 17 March 2004, 08:11 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi!
after upgrading my JBR 20 (not v2) from original 20go to
30go hd, when booting I get the above error, then a
rockbox screen but no directories or files. I can use F1
to see the parameters. USB mode is fine. If I boot the
original archos soft (ON + F1) it works! I thought it was
the limits, max files in directory that needed to be
modified. When I do modify it, nothing special happens,
if I reboot I lose the modif (back to 50). Maybe I should
go back to 2.1 rock solid version? (its flashed CVS
040126).

Thanks
bdyson@wanadoo.fr
This task depends upon

Closed by  Daniel Stenberg (bagder)
Wednesday, 17 March 2004, 08:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  Logged In: YES
user_id=1110

The particular bug that was initially reported is fixed. If
we should have a bug tracker entry for not working without
partitions, then I think we should make a separate entry for it.
Closing this.
Comment by Anonymous Submitter - Wednesday, 28 January 2004, 10:14 GMT

Me again. Its the next day and it seems to me that rockbox
doesn't hold any parameter modifs. It also occurs to me that
each disk acces (write or read) comes up with the same "Dir
Buffer is Full!" message. Curious, I tried to create a directory
manually, same message. When I connected via USB it had
indeed created the directory. Can I create a cfg file with the
necessary parameters (particularly max files in directory)
which is automatically read when booted? After all, in normal
operation when you modify a parameter it stays, even when
you reboot, how does it do it?
Thanks
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 28 January 2004, 10:26 GMT

Question: when you formatted your brand new HD, did you
create a partition table, or did you format the entire drive
as a FAT32 partition?

You should create a partition table with one primary FAT32
partition.
Comment by Anonymous Submitter - Wednesday, 28 January 2004, 16:01 GMT

Shouldn't really be doing this in work, anyway. I decided to
copy the v2.1 ajbrec.ajz into the root. Boot into archos soft
(F1+ON) then it boots to rb v2.1. Fine, it works! Ok,
something wrong with CVS 040126 me thinks. All I have to do
is flash with 2.1. Before that I was curious to see if I still had
the problem. Lo and behold it worked (CVS 040126)! When I
look at the max files in directory its at 400. I modify certain
parameters and note that when I reboot, they are still there
(not like before). So now it works and I'm almost happy
because I would still like an explanation. If anyone could
enlighten me...

Thanks
Comment by Anonymous Submitter - Wednesday, 28 January 2004, 16:11 GMT

I connected the new disk under W2K, scrapped the two
existing partitions and created one FAT32 primary partition
(quick formatted cos it was 2am). Paused to think about the
default cluster size (what would you recommend?) and took
the default (can't remember what it was). It does seem as
though I'm losing quite à few mb, rb tells me 27.9gb for a
30go disk.

Thanks for your help

Brad
Comment by Anonymous Submitter - Wednesday, 03 March 2004, 18:04 GMT

linusnielsen has the fix exactly right. After replacing the
original drive in a JBR, I couldn't get fdisk to run
properly in Win98SE (USB attached only). But, I was able to
format the entire disk as a FAT32 filesystem. The Archos OS
worked fine but I had the same problem with RockBox that is
documented here.

I did get a hint about the problem when I pulled the
batteries, reinserted, and got a directory display. However,
almost every action produced a screen asking about a missing
partition and reporting that the save failed.

Finally, I created a partition table with Partition Magic
(USB attach only again) and added a FAT32 formatted
partition for all of the available space. I reloaded RockBox
and all is well.

Detecting the partitioning issue during boot or allowing the
non-partitioned case (as Archos does) would be a nice
RockBox improvement.

-Bill
Comment by Daniel Stenberg (bagder) - Wednesday, 17 March 2004, 08:11 GMT

The particular bug that was initially reported is fixed. If
we should have a bug tracker entry for not working without
partitions, then I think we should make a separate entry for it.
Closing this.

Loading...