FS#1988 - .rockbox directory gets corrupted on startup/shutdown

Attached to Project: Rockbox
Opened by Anonymous Submitter - Thursday, 05 February 2004, 12:03 GMT
Last edited by Björn Stenberg (zagor) - Sunday, 14 March 2004, 16:26 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


If I try to flash any daily build after version 2.1 to my
rec 20, an error occurs. First everything is fine, but after
reboot (shutdown and start) everything in .rockbox dir
goes missing. In Resume -prompt if fails to resume. If I
answer Yes, message: Error accessing playlist control
file. I guess that means there isn't any.

Furthermore. If I try to play any mp3-file, I get this error:
*PANIC* Dir entry 1 in sector 0 is not free 2E 2E 20 20

Well, basically you can't do anything with it after that.
Somehow the rockbox dir gets corrupted. Only solution is
to install version 2.1.

Note that the bug report 870010 had some same
characteristics. The problem didn't go away with the
scandisk. It only fixed the corrupted dir.

Lari Pelkonen
This task depends upon

Closed by  Björn Stenberg (zagor)
Sunday, 14 March 2004, 16:26 GMT
Reason for closing:  Fixed
Comment by Linus Nielsen Feltzing (linusnielsen) - Thursday, 05 February 2004, 12:41 GMT

Did you try to use the Create Directory feature, or have you
entered the Recording screen (using the daily build)?
Comment by Lari Pelkonen (toleranssi) - Thursday, 05 February 2004, 13:18 GMT

I tried only to play few mp3-files (they played allright) and
then I shut off the device. After that the directory was
corrupted. I didn't try to record anything or create directory
via Create Directory feature.

So here are in step by step what I did:

Before flashing I had a version 2.1 without any problems.

Downloaded daily build (
Renamed .rockbox directory in jukebox to rockbox_old
Copied files from zip to jukebox
Roloed to daily builds ajbrec.ajz
Flashed using provided rockbox.ucl
Played few songs
(ok to this point)
Power off
Power on
Answered yes to Resume prompt
-> errors began to occur

Did I make some stupid mistake? I have been using previous
method when upgrading daily builds and versions.


Comment by Linus Nielsen Feltzing (linusnielsen) - Saturday, 13 March 2004, 22:16 GMT

Can you try this with 2.2, or the latest daily build?
Comment by Lari Pelkonen (toleranssi) - Sunday, 14 March 2004, 10:35 GMT

I tried with the daily build and everything seems to be running
smoothly. Damn. This device has never been this good. You
managed to decreace start up time. Nice. Even the video
playback works like a charm. Great.

This bug is wiped out.

Thank you,