Rockbox

Tasklist

FS#2027 - *PANIC* rec wrt: -1

Attached to Project: Rockbox
Opened by Steven Weed (sweed) - Friday, 27 February 2004, 03:47 GMT
Last edited by Steven Weed (sweed) - Sunday, 11 April 2004, 22:39 GMT
Task Type Bugs
Category
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Total newbie here, trying to make digital recordings.

Brand new Jukebox Recorder 20 Special Edition V2,
OS 1.40a running ajbrec.ajz
from rockbox-2.1-recorderv2.zip

HW INfo
ROM: 1.32
Mask: 0x0104
USB: positive
ATA: 0x200, master
PR: positive
Flash: M=BF D=D6
ROM CRC: 0x222F V1

Incidently, it seemed to hang up again when I tried
to get out of the Hardware info screen.

I really do not understand how to navigate the menus,
which is no doubt the root of the problem.
The left arrow key did not get out of the Hardware info
screen, but pressing stop for a second or so did..

The PANIC occurred after plugging in the USB cable
to get out of a seemingly hung and ineffective recording
session, trapped in the F2 screen. While connected
to Win XP, I confirmed that the recorded mp3
had no music so deleted it. After safely disconnecting
from XP, played a little of another mp3, then
started trying to navigate menus again and got
the PANIC message.

It would have been helpful if the ROCKbox manual
mentioned pressing the stop button for a long time
to escape from a PANIC.
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Saturday, 10 April 2004, 23:46 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Logged In: YES
user_id=259137

No reply. I'm closing this report.
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 01 March 2004, 18:35 GMT

Does this still happen with the latest daily build?
Comment by Linus Nielsen Feltzing (linusnielsen) - Saturday, 10 April 2004, 23:46 GMT

No reply. I'm closing this report.
Comment by Steven Weed (sweed) - Sunday, 11 April 2004, 22:39 GMT

I apologize for not responding sooner, but this is the first
weekend I've had my Archos connected to a PC since
submitting the bug. Anyway, I downloaded 2.2 and am unable
to duplicate the problem. In fact, I cannot get close to the
same scenario, since menus no longer hang during recording
and the USB connection is ignored during recording. As close
as I could come to the original circumstances was to power
off during recording, then attach USB, delete the recording,
disconnect, power on and play. RockBox 2.2 handled this with
aplomb. All in all, a worthwhile upgrade from 2.1 - booting
seems faster as well. Thanks for the nice code!

Loading...