Rockbox

Tasklist

FS#208 - Skips only with Car Cassette Adapter

Attached to Project: Rockbox
Opened by Phil Barnes (digger7045) - Wednesday, 04 September 2002, 09:27 GMT
Last edited by Daniel Stenberg (bagder) - Friday, 11 October 2002, 06:31 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To Linus Nielsen Feltzing (linusnielsen)
Operating System
Severity Low
Priority Normal
Reported Version Release 1.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Jukebox Recorder 6GB-USB Hard Drive (upgraded with
Toshiba 40GB Drive)
Serial Number: JBRHD101
Original Firmware: 1.17i
Current Archos Firmware: 1.27d

Bug report when using Rockbox V 1.3

This bug only occurs when connected to a car radio Cassette
Adapter (as per the Archos accessories pack)

Symptoms: When playing (either in 'normal' mode or a playlist),
with shuffle on or off.... the unit jumps to the next track prematurely.
This happens consistantly and regularly. This happens with the
Archos remote 'in-line' and without the remote connected.

I cannot reproduce this problem when playing the JBR through
headphones or a variety of domestic hi-fi amplifiers.

Suggestion: As Rockbox enables the remote to work (which the
Archos firmware fails to do reliably) it may be that the JBR is
reacting to a signal sent from the cassette player/adapter. If this
is the case it may be useful/simplist to have an option in the
firmware to enable/disable the remote control.

I suspect that my cassette machine is perodically automatically
searching for 'the next track' (or similar function) on an audio
cassette that does not exist (I cannot turn this function off on my
cassette deck). In so doing it may be sending a low voltage (?) to
the JBR through the cassette adapter which the JBR interprets as
a command to go to the next track.

I love Rockbox... but can't use it in my car with a cassette adapter
(which is when I use it most). I do hope you can fix this.

Many thanks. Rockbox rocks!!

Digger
This task depends upon

Closed by  Daniel Stenberg (bagder)
Friday, 11 October 2002, 06:31 GMT
Reason for closing:  Fixed
Comment by Linus Nielsen Feltzing (linusnielsen) - Friday, 06 September 2002, 12:51 GMT

If it happens even when the remote control is connected, it can't have
anything to do with any noise generated from the cassette player, since
the remote control is connected to the Rx pin, and not the cassette
adapter.
Is it by any chance so that you are using the adapter when
you are in the car, and the skipping is caused by a bumpy ride?
In any
case, we have worked a lot on other skipping issues, so you should try the
latest daily build to see if your problem is gone.
Comment by Alan Schneider (alanschneider) - Friday, 06 September 2002, 16:32 GMT

I am also having the same problem with my Archos Jukebox
studio 20 - running ver. 1.3 using my cassette adapter. I don't
have a remote control. I have seen a few situations where it
bails out early on a song and then if go back to song to listen
to it again, it plays it without difficulty.

I play this in my car and thought it might be caused by a
bumpy ride, but I don't think that's the case. I'll try the daily
builds and see if the problem disappeared.

Hope this helps.

Keep up the great work...
Comment by Phil Barnes (digger7045) - Monday, 09 September 2002, 11:35 GMT

Tried daily build 20000905 to see what happens. Strangely it is now not
possible to skip to the next track at all (using right arrow key on JBR)
when the machine is connected to the cassette adapter. There was
only one instance in over 2 hours of track skipping (I later checked the
MP3 concerned and it seems fine). The JBR behaves correctly when
disconnected from cassette adapter.

If the JBR is on and not connected to cassette adapter, and then the
adapter is connected the JBR screen goes black and freezes
requireing a reboot, at the moment the plug from the cassette adapter
is fully inserted.

I have 2 cassette adapters - different makes, bought in different
countries. Both behave the same.

I hope this is of some help in solving the problem.

The original skipping was definitely not due to a bumpy ride as I was
playing the JBR in my VW Camper parked on a campsite!
Comment by Anonymous Submitter - Saturday, 14 September 2002, 06:56 GMT

I support this issue, I have had the exact same issue
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 30 September 2002, 09:07 GMT

I have rewritten much of the remote control code to make it more stable.
Please try the next daily build and see if it has been any improvement.
Comment by Linus Nielsen Feltzing (linusnielsen) - Thursday, 10 October 2002, 14:48 GMT

OK, since there has been no response since we changed the remote
control code, we now consider this bug fixed.

Loading...