Rockbox

Tasklist

FS#2091 - battery meter read

Attached to Project: Rockbox
Opened by Matt Clapp (itsayellow) - Saturday, 20 March 2004, 03:26 GMT
Last edited by Linus Nielsen Feltzing (linusnielsen) - Friday, 05 November 2004, 07:15 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Release 2.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have the battery percentage shown on my "while
playing" screen, and I notice that for the first
~40sec. after powering-up the archos, it reads "-1%".
Also, the battery meter that should be in the
upper-left of the LCD is missing during that time.
After that warm-up time, the battery meter and battery
percentage display normally.

The same behavior was observed in rockbox2.1 (and maybe
in 2.0 as well? can't quite remember)

It's nice to be able to see battery right on power-up,
because sometimes I turn on my archos just to see how
its batteries are doing (i.e. if it needs charging.)
Now, I have to wait almost a minute to see this.

I have a Archos Studio 20 player, with rockbox2.2
ROM: 5.06
USB: neg
ATA: 0x300m
Mask: 0000
Flash: BF, D6
RomCRC: 222F
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Friday, 05 November 2004, 07:15 GMT
Reason for closing:  Fixed
Comment by Björn Stenberg (zagor) - Sunday, 21 March 2004, 16:10 GMT

This is a bug in the WPS tag - it should show "?" instead of -1. Fixed
now.

Immediately after powerup, the battery readings are incorrect. So we
don't display battery level until a little time has passed.

Loading...