Rockbox

Tasklist

FS#2130 - Grayscale framework & demo plugin

Attached to Project: Rockbox
Opened by Jens Arnold (amiconn) - Wednesday, 07 April 2004, 14:44 GMT
Last edited by Jens Arnold (amiconn) - Monday, 10 May 2004, 22:10 GMT
Task Type Patches
Category Plugins
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

This plugin contains a grayscale framework primarily
useful to incorporate grayscale display capabilities
into other plugins. This could be games, image viewers
or whatever else you could imagine.

The plugin itself contains a main() function that
demonstrates some of the capabilities of the framework.

The framework is heavily commented, so it should be
relatively easy to use. The available functions are
similar to these provided by the rockbox api for b&w
display except that there are no font functions. This
would require a change of the api.
This task depends upon

Closed by  Jens Arnold (amiconn)
Monday, 10 May 2004, 22:10 GMT
Reason for closing:  Accepted
Comment by Jens Arnold (amiconn) - Wednesday, 07 April 2004, 14:46 GMT

If someone wants to test the demo as-is, I've attached the
compiled grayscale.rock.

Hint: After the plugin has finished drawing, use the
"cursor" keys with and without holding "On" to see the
scrolling capabilities.
Comment by Jens Arnold (amiconn) - Wednesday, 07 April 2004, 18:41 GMT

If someone wants to test the demo as-is, I've attached the
compiled grayscale.rock.

Hint: After the plugin has finished drawing, use the
"cursor" keys with and without holding "On" to see the
scrolling capabilities.
Comment by Jens Arnold (amiconn) - Thursday, 08 April 2004, 21:53 GMT

New, improved version of the framework attached:
- safe replacement for lcd_update() call added
- core pixel routine is 10% faster
- various small optimizations and improvements
- updated descriptions in comments
Comment by Jens Arnold (amiconn) - Friday, 09 April 2004, 06:45 GMT

Grr, somehow Sourceforge mangled the uploaded files.
Re-uploaded them, additionally both files in a .zip
Comment by Blue Chip (bluechip) - Friday, 09 April 2004, 18:55 GMT

Great - the downloads are working fine now ...Tested with
Opera 7.21
Comment by Jens Arnold (amiconn) - Saturday, 10 April 2004, 00:04 GMT

Further improved version of the grayscale framework:
- core pixel setting routine another 14% faster
- core pixel inverting routine optimized
- reduced code size
Comment by Jens Arnold (amiconn) - Tuesday, 13 April 2004, 23:23 GMT

Reworked the framework a bit (again):
- core pixel routine slightly faster (only 2% this time)
- some other small tweaks
- reworked (extended/clarified) comments
- fixed the bug that the demo's main() function didn't react
to USB plugging as intended
Comment by Jens Arnold (amiconn) - Wednesday, 14 April 2004, 23:32 GMT

So here is another update:
- safe lcd_update() replacement mechanism rewritten so that it
does not cause flicker within the grayscale area any more
- minimal speed tweaks
Comment by Jörg Hohensohn (hohensoh) - Friday, 23 April 2004, 21:14 GMT

an extra "stride" parameter to the bitmap/graymap copy
functions, to allow copying subsets from a larger image

Loading...