FS#2172 - No charging while in USB-mode

Attached to Project: Rockbox
Opened by Joe Brown (mlsspa) - Sunday, 02 May 2004, 16:05 GMT
Last edited by Linus Nielsen Feltzing (linusnielsen) - Monday, 12 July 2004, 05:25 GMT
Task Type Bugs
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


Archos Model: Jukebox Recorder 20
Archos Firmware: 1.28
Rockbox: Version 2.2

I experienced that the Recorder seems not to charge
while in USB-mode.
I got my new Recorder last week and immediately
installed Rockbox on it. Then I began to copy my
MP3 files to the recorder. The recorder was all the
time connected to the charger, and the display even
showed it is charging.
After about 2 hours, the PC was suddenly no longer
able to access the Recorder and file copying aborted
(Windows showed an error message). I had to turn
off the Recorder and remove it from USB and the
After that, I were not able to turn the recorder back
on again: The booting screen from the original
Archos firmware showed up, but after 2-3 seconds
the unit switched itself off. So I connected the
charger again, and the unit began charging using the
Archos charging screen. After about 10 minutes of
charging, I removed the charger and booted into
Rockbox again. When Rockbox determined the
battery state, it showed they were almost empty, at
about 20%.
How can the batteries be drain, when the charger
was connected all the time (in USB-mode) and the
display even showed the animated battery icon?
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Monday, 12 July 2004, 05:25 GMT
Reason for closing:  
Additional comments about closing:  Logged In: YES

Well, I think we have cleared this up. It is not a Rockbox bug.
Comment by Mike Holden (mikeholden) - Sunday, 02 May 2004, 19:26 GMT

I presume you have a Recorder V2 if the charging screen
shows charging when only the USB is connected.

Basically, the USB does charge the unit, but only a little. The
charge supplied is not enough to sustain the unit during
heavy disk usage. You should at least plug in the wall-wart
as well, and ideally give it chance to recover every now and
then as well.
Comment by Joe Brown (mlsspa) - Monday, 03 May 2004, 18:27 GMT

to: mikeholden

I have not a recorder V2, I definitely have the old model.

Maybe you have misunderstood me: When the recorder is
in USB-mode only, it does NOT show that it is charging.
It shows charging while in USB-mode AND the charger
cable connected. But the batteries seem not to charge at
all, hence the unit causes trouble with the Windows
USB-connection when the batteries are getting low.
Comment by Mike Holden (mikeholden) - Tuesday, 04 May 2004, 09:54 GMT

Yes, sorry, I misunderstood what you wrote.

Part of what I wrote is still relevant to the older recorder
models though - during heavy disk use in USB mode, the
charger is not powerful enough to keep up with the demand
for power from the disk. You need to give it chance to catch
up sometimes, by keeping your transfer sessions shorter.

The charger should indicate charging, so I would advise you
to check your deep discharge and trickle charger settings.
Comment by Joe Brown (mlsspa) - Tuesday, 04 May 2004, 20:49 GMT

Thats what I suspected. The charger cannot deliver
enough current to power the hard disk and charge the
batteries at the same time. Maybe the problem can be
solved by using an charger which provides a higher output
current? The supplied one delivers max. 600mA at 9V.

Btw, deep discharge option is turned off, and trickle
charge is turned on.
Comment by Mike Holden (mikeholden) - Wednesday, 05 May 2004, 08:10 GMT

The charger charges the battery only. The battery supplies
power to the disk. The charger doesn't power the disk, lcd or
any other part of the jukebox.

The problem is that the disk is draining power from the
battery quicker than the charger can top up the battery. The
only solution is to break long transfer sessions into smaller
parts, so that the battery has time to recover after each hit.

This is not a bug in the code, it's just the way it is - there's
nothing we can do about it, other than the user to manage
the disk session properly!

If sure all of this is covered in either the ROckbox FAQ or the
battery FAQ on the Rockbox site. (If it isn't, it should be!)
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 12 July 2004, 05:25 GMT

Well, I think we have cleared this up. It is not a Rockbox bug.