FS#2189 - recfile: -4

Attached to Project: Rockbox
Opened by Anonymous Submitter - Monday, 10 May 2004, 19:55 GMT
Last edited by Linus Nielsen Feltzing (linusnielsen) - Friday, 05 November 2004, 07:04 GMT
Task Type Bugs
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Release 2.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


i've got the Archos FM recorder, using rockbox 2.2, and
HW info - ROM:1.23, Mask: 0x0304, USB: positive, ATA:
0x200, master, PR: positive, Flash: M=BF D=D6, ROM
CRC: 0x222F V1 and i think the Archos firmware version
number is 1.30j

The problem is that whenever I try recording from FM
the error message recfile: -4 always comes
up...sometimes it shows up automatically, sometimes it
shows up after a few minutes, but it always shows up.
The radio keeps playing, but I can't escape the error
screen and the files are never recorded. I just put
Rockbox on last night so I'm not familiar with it, but i
couldn't find anything on the site about that error, so it
might just be some easy fix that I don't know about.


This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Friday, 05 November 2004, 07:04 GMT
Reason for closing:  Fixed
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 26 May 2004, 06:46 GMT

Try this: enter and exit the normal recording screen once,
and then try to record from the radio screen. Please tell me
if that solves your problem.
Comment by Linus Nielsen Feltzing (linusnielsen) - Friday, 04 June 2004, 12:34 GMT

This is fixed in CVS.