FS#2241 - Freezes after idle time-out is exhausted

Attached to Project: Rockbox
Opened by James Stewart (wartstew) - Sunday, 27 June 2004, 03:48 GMT
Last edited by Linus Nielsen Feltzing (linusnielsen) - Friday, 05 November 2004, 07:16 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I also posted this as a comment on a much older (737051)
bug report, which I believe my problem is related to
because I experience similar power-off problems too that
began at the same time.

Model: JB6000
Firmware: 4.53
Current Rockbox: Daily-Build 20040625

Some "Debug" info:

Batt: ~5.8
(while powered from orignal "Kings" USA issued adapter).
Note, my batteries are also currently failing, giving only
about 3 hours of play time. I'm due for new ones, these are
the original ones that came with the unit several years ago!

HW info:
ROM: 4.53
USB: neg
ATA: 0x300m
Mask: 0000
Flash: ??,??
RomCRC: 222F

The Specific Problems:

As I was following the daily builds, sometime during the
Rockbox development, maybe about 3 months after the
major cool "car adapter" mode came out, (almost a year
ago?) my JB6K would stop turning off while external power
was connected. Here are the details:

1) When the "stop" button is pressed and held for a long
time while unit is playing, nothing happens, the unit
continues to play. A quick press of the stop button works
normally and stops the play mode

2) If the unit is stopped, and the stop button is pressed for
a long time, it will display "Battery Charging", but then will
return to the file browsing screen as soon as the stop button
is released.

3) Finally, when external power is removed, then after the
idle time-out is exhausted, the display will freeze, the
backlight will stick on, and all buttons will be non functional
except the "stop"(power-off) button (and then only while the
external power is removed), until I power cycle the
machine. This problem really causes problems when
using the "car adapter" mode.

And of course the limited power-off command works just fine
using the last Archos "mod" file.

If no one wants to work on this problem, can I at least get a
vintage version of Rockbox that works with my player
correctly. I failed to save old versions. I can't remember if
Ver 1.4 had the Car-adapter-mode or not, The classy "fade
mode" feature would be nice too. Probably the earliest
versions available with these features I would be happy with
for the rest of the lifetime of my player.

I can help track this problem down a little if I knew where to
access old changelogs and matching source code for the
era where the problem started. Sorry I don't have the exact
date, but it was around the first time someone complained
on archosjukebox6000 Yahoo group that they couldn't turn
their unit off with Rockbox and external power and either
Bjorn or Linus responded to this complaint that the unit
really never turns off anyway when plugged into external
power, so why do you wish it to say that it did? I suspect this
person was having the same problem I and others have.

Thanks for donating otherwise great software to the general

James Stewart <>
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Friday, 05 November 2004, 07:16 GMT
Reason for closing:  Fixed
Comment by Linus Nielsen Feltzing (linusnielsen) - Sunday, 27 June 2004, 09:18 GMT


filing three issues in one bug report is not the best thing
to do. It is much better for everybody if there is one
report per issue.
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 14 July 2004, 10:08 GMT

Issue 3) is now fixed in CVS.