FS#2268 - Recording does not end

Attached to Project: Rockbox
Opened by Paul van der Heu (paulheu) - Thursday, 15 July 2004, 00:23 GMT
Last edited by Linus Nielsen Feltzing (linusnielsen) - Monday, 22 August 2005, 14:09 GMT
Task Type Bugs
Category Recording
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


for some CVS builds now when I do a (long) recording
rockbox won't come out of teh recording screen (unless
I turn it off).

Hit record and let it run

Before it would blink the red led every now and then to
indicate (I assume) the buffer is being written. Now the
red led stays on all the time only to go off for short
blips, but not a regular intervals. After a while it won't
turn off at all.

After some time hit OFF, it appears as though the
recording is ending, but the red led says on (of starts
blinking fast) and teh recording icon (dot) does not turn
into the stop icon (filled square). Turning the unit off
(obviously) destroys the file leaving you with no

Also sometimes during recording rockbox just freezes (no
more movement on the LCD) and turning it OFF is the
only way out..
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Monday, 22 August 2005, 14:09 GMT
Reason for closing:  Out of Date
Comment by Linus Nielsen Feltzing (linusnielsen) - Thursday, 15 July 2004, 04:02 GMT

The behaviour of the red LED has changed since a while back.
It will now blink until you start the recording, and stay on
during the recording, as an indicator. It will turn off
during disk access, i.e it is inverted.

I can't explain the freezing though...
Comment by Paul van der Heu (paulheu) - Friday, 16 July 2004, 21:16 GMT

Well, recording is completely broken for me, I returned to the
2.2 release because the dailies simply do not work. I get
MANY bad frames, I used to get 1 or 2 every now and then,
currently they are in the hundreds. Tried reformat of HD but
that does not help. This is using 48 KHz, Q7 and digital in.
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 21 July 2004, 08:28 GMT


please try this version and tell me if it works better:
Comment by Paul van der Heu (paulheu) - Tuesday, 27 July 2004, 03:28 GMT

After a complete reformat and using CVS 040718 I got one
good recording but after the second live set when I pressed
OFF the red led started to blink quickly for a while and after
that rockbox was completely frozen. Needles to say the
resulting file was well mangled and what I got was a repitition
of what seems the last buffer content. The file had this bit
about 5 times in a row after which all I have is silence. weird
thing is the filelenght is about right..

Running it through mp3fixer got massive hits with bad frames,
running upto 25-75 bad frame blocks..

As I am currently way to busy to free some time to do
extensive testing I'm back with v2.2(release) for now.
Comment by Paul van der Heu (paulheu) - Wednesday, 11 August 2004, 20:49 GMT

The provided special build worked much better, although I still
get a relative large number of bad frames, much more then
with v2.2
Comment by Paul van der Heu (paulheu) - Sunday, 22 August 2004, 10:22 GMT

Well, I added some mp3s to my archos yesterday and it's now
about 35% full (40 GB capacity). I still have the 'special build'
linus made loaded, but again recording went bad. I recorded
three sets of 45 minutes, and each one was unsucessfule as
rockbox frooze after hitting OFF to stop recording.

SO again we go back to release 2.2 which is fine..
Comment by Paul van der Heu (paulheu) - Sunday, 22 August 2004, 16:27 GMT

I put last nights 'recordings' up on my server at so you can check
the files to see itf there's any clues as to what goes wrong..

There's so much bad frames, about 2/3 of the file gets lost
when I run it through mp3fixer
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 05 October 2004, 08:40 GMT


I'd like you to try this version:

This is version 2.2 with one small modification, it enables
the CRC protection for the MP3 frames.
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 22 August 2005, 14:09 GMT

No reply. I'm closing this report.