Rockbox

Tasklist

FS#2305 - Playback stops on disk access

Attached to Project: Rockbox
Opened by NatG (natg) - Monday, 16 August 2004, 18:21 GMT
Last edited by NatG (natg) - Wednesday, 09 March 2005, 14:35 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Release 2.2
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Hi,

First of all my complete kudos and respect for building
this wonderful OS. I love the features and the whole
concept of an alternative to corporate software, and am
thus a big fan of open source projects.

Two things are happening since I upgraded my JBR 20
(Archos firmware v 1.28) to Rockbox 2.2.:

One, on a full battery (or partially charged) the machine
will stop playing, usually on the first song, about 2/3 to
3/4 through the song when it goes to read the disk.
Sometimes I get lucky and it will play 4 or 5 songs
before this happens, but most of the time it happens on
the first song every time.

The other thing that happens is that while playing with
the charger plugged in, it will quit on me suddenly after
anywhere from one to several hours.

Neither of these problems appear to be the Red Led
Dead bug, as the red LED only comes on briefly and the
machine doesn't actually crash, it just returns to the
menu from which the song was run.

I have tried reinstalling Rockbox 2.2 and also the daily
build of 8/14/04, both with no success. The machine is
not cold or moving when this happens.

Please let me know if there's any more info I can
provide. I am not an expert programmer but I'm happy to
do whatever I can to help diagnose this.

Thanks,

Nat
This task depends upon

Closed by  Daniel Stenberg (bagder)
Wednesday, 09 March 2005, 10:43 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Logged In: YES
user_id=1110

This report is very old and concerns a Rockbox version from eons ago.

Lots happen in the Rockbox all the time, and if you still have
problems with this matter I suggest you file a new entry.
Comment by NatG (natg) - Monday, 16 August 2004, 18:40 GMT

Some additional info: the majority of the time this happens at
precisely 1:37 into the first song playing. Occasionally it will
play past this point and halt a minute or more later, but
always when it appears to be reading the disk. Regardless of
when it happens, it always pauses for a fraction of a second,
resumes for one or two seconds and then stops completely.

Sometimes when I press play again it will seem to start but
then stop before it begins playing. Then if I press play again it
will actually start and play until it halts at 1:37 or later.

Hope all this info is useful.
Comment by NatG (natg) - Monday, 16 August 2004, 18:41 GMT

Some additional info: the majority of the time this happens at
precisely 1:37 into the first song playing. Occasionally it will
play past this point and halt a minute or more later, but
always when it appears to be reading the disk. Regardless of
when it happens, it always pauses for a fraction of a second,
resumes for one or two seconds and then stops completely.

Sometimes when I press play again it will seem to start but
then stop before it begins playing. Then if I press play again it
will actually start and play until it halts at 1:37 or later.

Hope all this info is useful.
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 17 August 2004, 17:24 GMT

I have no idea what may be causing this. Please try to set
Disk Poweroff to "No", and tell us if it helps.
Comment by NatG (natg) - Wednesday, 18 August 2004, 01:27 GMT

Linus,

I set Disk Poweroff to "No" and it has not changed anything
that I can tell. Today it ran for a while (30-45 minutes) while
charging and then just stopped. One thing I noticed is that
after it stopped I saw that the battery indicator was no
longer 'filling up' continuously as it does while plugged in. I'm
not sure but I believe when it stops while charging, it's when
the battery is close to or fully charged (Deep Discharge=Y,
Trickle=N).

Later today I ran it on battery with a full charge and it did
well for about 1.5 hours and then stopped. I restarted 4 or 5
times and each time it stopped at 1:37 (first disk access I
think). The last time I started it it kept playing and has been
playing for 20-30 minutes. The battery is currently reading
60%.

Thanks for the response. Please let me know how I can help
you to diagnose this. I think I understand the debug readings
(not what they all mean, but how to see them).

Nat
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 18 August 2004, 09:41 GMT

Two more things:

1) Does it work OK with the original firmware?

2) Have you tried to replace the batteries?
Comment by NatG (natg) - Wednesday, 18 August 2004, 19:25 GMT

Linus,

Yes it seems to work ok with the original firmware, and no, I
have not tried changing the batteries. Given these symptoms
could that really be suspect?

Last night, after halting 4 or 5 times in a row, it finally ran off
the battery for quite a while, down to about 20%. This
morning I ran the unit off the charger (even though it had
close to a full charge) while playing. The battery indicator as
usual showed it 'filling up' repeatedly. After an hour or two
the playback suddenly stopped, and I noticed the battery
display was no longer 'filling up' but instead sitting at about
the halfway point. In debug-view io ports it showed the
battery at 56%. It seems odd to me that if I plug it in with
almost a full charge it would run on the charger for a while
and end up with less of a charge.

Just to clarify: the settings are currently Deep
Discharge=Y/Trickle=N; do I understand correctly from the
manual that on this setting the unit will actually run off the
batteries until it falls to 10%? This would mean that whenever
I unplug to run it off the batteries it probably won't have a
full charge. Is this right?
Comment by VulnoX (vulnox) - Wednesday, 18 August 2004, 23:04 GMT

I am sorry to see someone else with this problem, but am
kind of glad because maybe we can get enough attention and
people working on it to find a solution.

I have been trying to fix my dad's Archos Recorder 15 for a
little while now when it all of a sudden decided to do the
same stuff.

I guess the 2.2 firmware is when it started, and I have been
messing with settings to try and fix it. He usually has it
plugged in in his truck, and on a power adapter. I have had
it happen both on and off the AC or DC adapters, as well as
on battery's.

It happens within the first few disk access'. Sometimes it
will last a song or two, or maybe even a few hours. But
there is no consistancy. Right now I have it set to not
spindown the disk for 70 seconds and I will see what happens.

Please help me and natg find a solution!
Comment by NatG (natg) - Thursday, 19 August 2004, 16:34 GMT

Glad to hear I'm not crazy and that I'm not the only one
experiencing this problem.


Two new observations:

One, it appears that after running Rockbox off the charger
for a period of time, charging will just stop and it will start
running off the battery. I've noticed that while running off the
charger (with the battery indicator filling up), sometimes the
debug/view io ports/Batt: reading is -1% and other times it
has an actual reading, usually between 85-100%. This is
what has happened this morning. It ran on the charger for a
while, battery indicator filling up, debug/Batt: reading -1%
(that's minus). 10-15 minutes later the reading said 90% but
the indicator was still filling up. Then a few minutes later the
indicator stopped 'filling' and stayed steady at aproximately
the 90% mark, and the debug/Batt reading showed 88%.
Subsequent times I checked over the next hour the % figure
decreased and then increased, but the battery indicator
never showed it charging anymore even though it was still
plugged in and had not been moved.

Two, and this is quite strange, the song-stops-playing
problem does not seem to be happening while Rockbox is in
one of the function key menus. I left it on the debug/view io
ports screen to watch the battery and noticed the problem
never happened. It played on and on without stopping. I also
tried it on the first F1 menu (the one with Bookmarks, Sound
Settings, General Settings, etc) and the same is true-- no
problems so far. So, at least while in the F1 menus this
problem does not seem to occur.
Comment by Markus Braun (malle) - Thursday, 19 August 2004, 18:36 GMT

I experience the same problems, again. Back in January I
(and some others) had the same problems
(http://rockbox.haxx.se/mail/archive/rockbox-archive-2004-01/0543.shtml,
http://sourceforge.net/tracker/index.php?func=detail&aid=878083&group_id=44306&atid=439118)
A unrelated change fixed the problem that time, but now
experience the same BUTTON_OFF events again.
Comment by NatG (natg) - Thursday, 19 August 2004, 18:45 GMT

A new and significant observation: this seems to be related
to the Red Led Dead bug (or a variation thereof)

As I said in the previous post, this 'stops-playing-mid-song-
on-disk-access' problem does NOT occur when the display
shows one of the F1 menus. However, what has happened,
twice now, is that after a long period of playing without any
problem with the screen on one of the F key menus, playback
eventually freezes with the red led permanantly on. This just
happened for the second time when I left the machine playing
while I went to lunch. Playback is frozen. The WPS shows the
track info as if it were paused (except the 'play' arrow is on,
not the pause symbol). However unlike what I've read about
the other occurances of Red Led Dead, the clock still shows
the correct time, the menu buttons DO work, AND the battery
status indicator is back to repeatedly 'filling up' again (it had
previously remained at a steady level even tho the charger
was plugged in). So the player itself is not frozen, just the
playback and the WPS.

I know this is a lot of information. Hope this is helpful.
Comment by Anonymous Submitter - Thursday, 19 August 2004, 22:10 GMT

I am thinking about getting new battery's and seeing if that
fixed the problem. From reading other posts, it doesnt sound
like the system runs off of a charger (AC/DC) all the time
when plugged in. It sounds like it runs off the battery's to a
certain point and then the charger just refreshes them.

If that is the case, it is possible that the battery's, which
have had a lot of use, especially in his player, have simply
lost their ability to provide the correct amount of ma or
voltage. So I will try to replace them and see if that solves
the problem.

But after reading your message about it being on the Fkey
and not having the problem, I am not sure right now. It cant
hurt to try though right? You say it gives a red light error, so
maybe it is the battery's. They kind of crap out when trying
to boot the disk, so the player reads it as a disk error.

I charged the battery's last night, and when I turned it on
this morning, it read 17% full. Either Rockbox just wasnt
reading the battery's right, or these have finally given up.

Good luck!
Comment by NatG (natg) - Wednesday, 01 September 2004, 14:21 GMT

Linus & others:

I've been using the Archos on the original firmware with no
problems, so it isn't the batteries or the machine itself.

Is this bug still an active issue, and if so, is there anything we
users can do to make it easier for you all to diagnose? I know
everyone is busy; please let us know how we can help. I've
tried to provide as many details as possible.

Thanks.
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 01 September 2004, 20:22 GMT

I'm beginning to suspect that this is the same bug that
other people have reported, that Rockbox sometimes sees
bogus key events, possibly caused by a glitch in the A/D
conversion.
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 05 October 2004, 11:30 GMT

I have fixed a bug in he button driver that could be related
to this. Can you try the latest daily build and tell me if
it is any better?
Comment by NatG (natg) - Wednesday, 06 October 2004, 15:13 GMT

Linus,

Thanks for working on this! Unfortunately, the problem is still
occurring with the latest build. It played for several hours last
night and then the Red Led Dead bug happened. This morning,
several times in a row, it just stopped playing (as if the stop
button event fired) without the Red Led.

Thanks again, and please don't give up! I miss the Rockbox
OS (the factory one suuuux)!

Nat
Comment by NatG (natg) - Wednesday, 06 October 2004, 15:22 GMT

Another observation:

Now, after playback stops, hitting play on a song suddenly
switches to the Playlist menu. This happens three or four
times in a row-- cursor is on song title -> play -> now we're
in the Playlist menu. Sometimes pressing play will cuse the
disk to spin up and then nothing happens, the cursor stays on
the song title as if nothing had happened.
Comment by Linus Nielsen Feltzing (linusnielsen) - Thursday, 07 October 2004, 05:10 GMT

Wow. It seems like your device has awfully sensitive keys.
The reason that it enters the Playlist menu is that the
context sensitive menu pops up when you hold Play, a feature
we added a couple of days ago. Which version of Rockbox are
you running now? You should run the very latest one.

The Stop events are generated because there is a voltage
drop when the hard drive spins up, giving a short glitch on
the input pin for the STOP key. We have tried (with good
success in all cases but yours) to combat this by reading
the input twice.

Your machine must have longer drops than most other
machines, and that leads me to believe that you might have
some battery problems as well.
Comment by NatG (natg) - Thursday, 07 October 2004, 13:20 GMT

OK, well perhaps I am holding the Play key for too long.

As for the voltage and batteries: is there some way to
confirm that the voltage drops are longer than usual, possibly
with the battery indicator?
Comment by Linus Nielsen Feltzing (linusnielsen) - Thursday, 07 October 2004, 13:31 GMT

You can probably only verify it with an oscilloscope.
Comment by Anonymous Submitter - Thursday, 04 November 2004, 19:47 GMT

I have an Archos Jukebox 6GB model (with 10GB drive
upgrade), internal firmware version 4.53, and running RockBox
Version "CVS-040819". I am experiencing the exact same
symptoms. On battery, plays one song or so, the red disk
light comes on for about 1/2-second, goes out and goes back
to the folder display, showing songs. One thing to add,
however, in that fiddling with it, if I started a song playing
and then went in to one of the other menus (like volume, for
example), as long as I was hitting buttons, it kept playing. It
apparently just doesn't like being button-idle for that amount
of time.
Hope this helps in the quest for a fix...
Thanks,
Joe J.
Comment by Linus Nielsen Feltzing (linusnielsen) - Friday, 05 November 2004, 06:10 GMT

Mr nobody,

You should consider upgrading to 2.3. I believe we have
fixed that issue.
Comment by Daniel Stenberg (bagder) - Wednesday, 09 March 2005, 10:43 GMT

This report is very old and concerns a Rockbox version from eons ago.

Lots happen in the Rockbox all the time, and if you still have
problems with this matter I suggest you file a new entry.
Comment by NatG (natg) - Wednesday, 09 March 2005, 14:35 GMT

Funny you should mention. Two weeks ago I downloaded and
installed the latest (at that time) version. The problem still
occurs, but:

(1) Red Led Dead occurs more frequently. In the original
problem it was not actually RLD - it just behaved as if
someone had hit stop. I could replay immediately.


(2) It is more random than ever. Sometimes it will play for
HOURS without stopping. Then out of nowhere I get RLD or it
just stops. What is ALWAYS the same is that when it stops
it pauses briefly (like .25 sec), plays a few seconds longer
then stops completely.

Continued thanks to all who work on this.

Loading...