Rockbox

Tasklist

FS#2316 - "Load last bookmark?" does not wait for input

Attached to Project: Rockbox
Opened by Alex Pleiner (projekt21) - Wednesday, 01 September 2004, 09:28 GMT
Last edited by Linus Nielsen Feltzing (linusnielsen) - Friday, 05 November 2004, 07:05 GMT
Task Type Bugs
Category
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Device: FMR, CVS-Build: 2004-08-30

When I configure my rockbox to ask "Load last
bookmark?", it displays the according screen but does
not wait for my input. It continues as if I had
selected "no". The X11 sim does the same.

If I replace

button_clear_queue();

with

while (button_get(false));

in bookmark.c everything works again. BTW, there are
still 4 of those while-loops in that file and only one
button_clear_queue.
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Friday, 05 November 2004, 07:05 GMT
Reason for closing:  Fixed
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 01 September 2004, 09:34 GMT

This was due to a bug in button_clear_queue() that I fixed
earlier today.
Comment by Alex Pleiner (projekt21) - Wednesday, 01 September 2004, 09:49 GMT

Thanks for your quick reply. I am within my office, so I
will check this later, but the X11 sim (with button.c,
v1.49) still does not wait for input. Is this correct?
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 01 September 2004, 10:09 GMT

The X11 simulator doesn't use button.c, it uses
button-x11.c, so I don't know what might cause the bookmark
bug there.
Comment by Alex Pleiner (projekt21) - Wednesday, 01 September 2004, 10:23 GMT

I have to apologize for not doing a bit research before
posting. Well, from button-x11.c:

void button_clear_queue(void)
{
}

Thanks for your help.

Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 01 September 2004, 10:27 GMT

Please note that the empty clear function is not the cause
of this bug. It is supposed to be empty since the X11
simulator doesn't use a queue, but does raw reads instead.

Loading...