Rockbox

Tasklist

FS#2376 - Computer won't recognize drive

Attached to Project: Rockbox
Opened by Anonymous Submitter - Monday, 01 November 2004, 23:54 GMT
Last edited by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 28 December 2004, 11:53 GMT
Task Type Bugs
Category Drivers
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Release 2.2
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

I have an Archos V2 recorder that was rock solid since
updating to the Roxbox firmware 2.2, especially when
connecting to my computer. Recently (after upgrading
to Windows XP Professional Service Pack 2) when
connecting to my computer, the drive comes up "unknown
device" in device manager. I've downloaded the usb
drivers from Archos'
website hoping it would would solve the problem, with
no such luck. The unit still plays and is fine any
every other way. Is there an issue with Service Pack 2
and these drives?


Email- Fromu2e@netscape.net

PS - In the Harware Info Screen: USB: positive, but PR:
negative. Is this signifigant.
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Tuesday, 28 December 2004, 11:53 GMT
Reason for closing:  Rejected
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 02 November 2004, 00:05 GMT

I fail to see how this is a bug in Rockbox, since it worked
before you installed SP2.
Comment by Anonymous Submitter - Tuesday, 02 November 2004, 03:15 GMT

The question is -- are there reported compatablity issues with
Roxbox and Windows SP2? Or is it the mp3 player? How could
I tell? Is it signifigant that in my hardware info screen the PR
is negative?
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 02 November 2004, 07:22 GMT

No, there are no reported compatibility issues.

In fact, it is interesting that they aren't both the same
polarity. They should be.

Have you tried different USB ports?
Are you using a USB HUB?
Do you have an more USB devices on the bus?
Comment by Anonymous Submitter - Tuesday, 02 November 2004, 10:09 GMT

I have tried using the unit on different USB ports,
different hubs and on different computers. I get the same
error. Could there be something wrong with the unit that
would create different polarity? Is this a hardware
problem?? Could I use the Roxbox software to reset it back
to a working condition? Thank you for all your help.
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 02 November 2004, 10:18 GMT

I'm afraid it sound like your unit is broken somehow. What
happens on the jukebox when you insert the USB cable? Is it
any different if you have the charger connected?

BTW, I just examined the rockbox debug code, and the
negative polarity is a false alarm.
Comment by Anonymous Submitter - Tuesday, 02 November 2004, 21:51 GMT

Thanks for the info. I don't know how the device is broken.
The usb cable feels the same when inserting into the
device. When plugged into my usb cable and charger I get
the same error.
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 02 November 2004, 21:55 GMT

Again: what happens on the jukebox when you insert the USB
cable? Does it enter USB mode?
Comment by Anonymous Submitter - Wednesday, 03 November 2004, 11:19 GMT

Yes. Archos recognizes usb connection (the usb symbol
appears on screen). But the computer comes up with an error
messsage that the device is unknown.
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 03 November 2004, 11:46 GMT

Then I have no idea what it could be. Since it fails on
other computers as well, I think the jukebox may be broken
somehow. Is it any different if you squeeze the jukebox a
little, for example pushing on the battery lid?
Comment by Anonymous Submitter - Wednesday, 03 November 2004, 20:12 GMT

Squeezing the rockbox as no effect. The usb port must be
busted. How do I go back to the old firmware?
Comment by Linus Nielsen Feltzing (linusnielsen) - Thursday, 04 November 2004, 06:03 GMT Comment by Anonymous Submitter - Thursday, 23 December 2004, 18:59 GMT

I am having the same problem
computer recognizes the usb link (usb symbol on taskbar and
archos LCD), recognizes hardware, but DOES NOT recognize
drive.
Rockboxx was all good until two weeks ago when my
computer received a Windows upgrade/patch/pack...
Please HELP!
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 28 December 2004, 11:53 GMT

This is evidently not a Rockbox bug, so I'm closing this bug
report. If you need help, please join the mailing list or
post a question in the forum.

Loading...