Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority High
  • Reported Version Release 2.3
  • Due in Version Version 3.0
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by cybertoast - 2004-11-25
Last edited by christi-s - 2006-03-19

FS#2402 - Playback stops mid-tune intermittently

Rockbox ver 2.3, OS ver 1.30j. Archos Jukebox FM
Recorder v2.

Playback stops mid-song. Frequency appears to be pretty
high (at least once every 2-3 days of regular play).
Could happen within 10 minutes or after several hours -
I have not determined anything consistent about the
issue. The red led comes on at the same time. The only
way to continue with playing or going back to a
different tune is to shut-down and restart the unit.
Shutdown requires at least an 8 second hold-down of the
off button (whereas the usual shutdown only requires 3
seconds). I tried a variety of different combinations
of buttons to get the unit going, but could not get it
to continue playing, or skip out of the track. Also,
the unit does not shut itself off after 30 minutes when
in this state, so it appears that the unit thinks play
is legitimate (idle timeout does not ever expire).

Problem occurs both with playlists and with playing
files in directories. There does not seem to be any
commonality between the files played (i.e., encoding,
size, etc.).

Unit has 8GB free, so it does not appear to be a space
issue.

Things I have not yet tried:
1. Rolling back to an earlier version, or using latest
build from CVS (I’m going to test that over the weekend).
2. Formatting the disk and starting again, which I’ll
try next week.

Closed by  bagder
2006-03-30 08:25
Reason for closing:  Out of Date
Additional comments about closing:  

No response

Project Manager

This sounds like the common Red LED Death problem. The hard
drive stops responding, probably because the jukebox was
shaken. Go to “Menu→Info→Debug→View disk info” and tell
me which type of hard drive you have. If you have a Hitachi
DK23DA or DK23DC, it is definitely the RLD problem.

Is there any solution to this, such as replacing the
hard-drive with a better disk? Or is this a “live with it” issue, which I need to deal with by getting a different
unit? :-)

Thanks for the help, BTW.

Project Manager

Replacing the disk is the recommended solution.

Project Manager

Can you please try a recent daily build and see if the
problem is still present?

I’m seeing the same issue on 2.5 using my Archos Recorder
10, nearly every song stops midways, I do have a DK23DA
harddrive so it might be the dreaded RLD problem, however
the changelog says that this should be fixed.

This definately wasn’t a problem with earlier versions of
Rockbox

Please let us know if this is still a problem with the current daily builds.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing