FS#2449 - Recursive playlists only load one sub-folder

Attached to Project: Rockbox
Opened by Anonymous Submitter - Monday, 14 February 2005, 23:19 GMT
Last edited by Daniel Stenberg (bagder) - Wednesday, 09 March 2005, 10:32 GMT
Task Type Bugs
Category Playlists
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Data layout
where ARTIST is the name of the artist, and then
ALBUM is the name of each album by that artist.

"Recursively Insert Directories" set to ON or ASK

-Navigate to \Music
-Highlight an artist that has more than one album (But
do not select it)
-Hold down ON and press Play
-Select "Playlist"
-Select "Insert"
-If set to "ASK", press Play

-Only the first album in the artist subdirectory gets put
into a playlist

Expected Result:
-This used to put in all the albums in the directory I
highlighted into a playlist. This made it easy to say "I
feel like listening to The Beatles today".

Hardware: Archos JukeboxRecorder 20 (Black bumpers,
non-flashable, original style JBR20101). Upgraded with a
40 gig HD. Rom 1.28

This task depends upon

Closed by  Daniel Stenberg (bagder)
Wednesday, 09 March 2005, 10:32 GMT
Reason for closing:  Fixed
Comment by Anonymous Submitter - Wednesday, 16 February 2005, 01:57 GMT

I have the exact same issue. Recursive insert is broken in
Comment by Anonymous Submitter - Tuesday, 22 February 2005, 16:15 GMT

This is now working with CVS-050222 - Thanks, Linus!!