FS#2512 - Song gets repeated (shuffled playlist)

Attached to Project: Rockbox
Opened by Thomas Kobler (kobler) - Monday, 30 May 2005, 22:12 GMT
Last edited by Daniel Stenberg (bagder) - Wednesday, 01 March 2006, 08:07 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Recorder 8MB 20050523

When shuffling a playlist, sometimes almost every third
to fifth song gets played twice. Fully. From start to
end. (Playlist is about 13000 songs)
It shows up in the playlist (editor) only once and the
bahaviour is not repeatable by skipping back and
replaying the song.

The songs in the playlist before and after *are there*
and gets played, when selected from the playlist editor. didn't have this

Anything else you need to know? Should I test something?

Thank you.
This task depends upon

Closed by  Christi Scarborough (christi-s)
Sunday, 19 March 2006, 12:25 GMT
Reason for closing:  Fixed
Additional comments about closing:  This should no longer be a problem. Please re-open if this is still occurring with the latest daily build.
Comment by Thomas Kobler (kobler) - Friday, 03 June 2005, 06:00 GMT

In fact a song gets skipped and the next played instead.
Therefor played twice. But when skiping back. the skipped
song plays! The problem shows up after some playing time
(maybe several hours).
And from then on rather often (every 3. -5 song)
When skipping back and forth sometimes the song length and
bitrate is 0 or ? and once there has been no sound at all,
but counting.
I thing it's nothing with the song data, cause it happens
with very differnt material, but I didn't add/change any
songs since the rockbox update.
Thank you.
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 07 June 2005, 06:18 GMT

This sounds to me as if there was a failure when reading the
songs from disk, maybe due to low battery. Does it behave
the same when you run the 2Mb version?
Comment by Thomas Kobler (kobler) - Tuesday, 07 June 2005, 22:36 GMT

After roloing the daily 2MB Build and plugging the charger
(actual voltage > 5.3V) it happend again. Not the often, but
I had it at least twice in two hours. Song gets skipped and
next played twice.
When playing it from the playlist viewer, they all seem to
play fine.

These current versions might even truncate songs. I'm not
completely sure, but I'm wondering if I really have that
much incomplete songs on the box. But I've got to verify
this, next time, when I come across a cut end.
Thank you.
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 07 June 2005, 22:50 GMT

This definitely sounds like disk reading problems. Could you
try the daily build from May 10 and see if the problem is
there too?

Comment by Thomas Kobler (kobler) - Wednesday, 08 June 2005, 06:09 GMT

I've got the version of 5. may in Flash and the problem is
Should I test 10. May, too?
I only know that 26.dec. 04 is O.K. Are there any versions
of februray or march available to test?
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 08 June 2005, 06:26 GMT

How long is it since you tested the 26 dec version?
Did you test it recently, or do you just remember that it
worked back then?
Comment by Thomas Kobler (kobler) - Wednesday, 08 June 2005, 06:38 GMT

SORRY, I always tend to twist year and day. The bad version
in Flash is 23.may.2005. I'll give the 10.may.2005 a try.
Sorry, again.
Comment by Thomas Kobler (kobler) - Wednesday, 08 June 2005, 06:40 GMT

I used the 26.dec 2004 version till then.
Comment by Thomas Kobler (kobler) - Wednesday, 08 June 2005, 12:41 GMT

The 050510 (10.may 05) daily build has the problem, too.
After listening for about two hours, I noticed the first
skipped song: #116 of 10000 playes second time.
When skipping back to 114, 115 plays fine, but I'm sure I
haven't haeard it before. A second skipped occured at 126.

Is there any earlier version to test (The december version
I've tested again yesterday, and it has been fine)

Thank you!
Comment by Thomas Kobler (kobler) - Monday, 20 June 2005, 11:34 GMT

A test on a second unit (8MB recorder, too) has not show the
misbehaviour. But the working (older) unit has only a disk
with 2MB harddisk cash. The newer recorder with the problem
has a 100G disk with an 8MB cash. As far as I know, this is
the only difference with these two devices. For the test I
copied the same files and (preshuffled) playlist to both
units, which showed the problem before. I can not find any
pattern or feature of the skipped file(s).
Again: the december version works and it is not with any
special file conntend, cause after rebooting the unit plays
fine for a while.
The bug on the newer recorder *is* repeatable to some extend.
When I skip back not one, but three tracks, after it has
skipped one, it does the same again! The playlist editor
says: playing 10, but in fact it plays 11 alread and also
show this in wps.
The skiped song doesn't get played at all. The previous and
the following track gets played fully, without a problem.
When writing the shuffled playlist to disk and rebooting the
recorder it sometimes repeats this behaviour, but only
sometimes. But never on the second recorder with the 60G/2MB
Could anybody confirm, that (s)he has a recorder, with a
disk with 8MB cash, which doesn't skip songs (lets say in a
list of 50)?
Thank you.
Comment by Anonymous Submitter - Friday, 19 August 2005, 09:54 GMT

I'm using the 050709 version in flash and it happened in
nomal play order as well - however did not had the time to run
any further tests. It happend on directories with more then 40
files that belong to ono audiobook. It repeats the song several
times completely. Older version did not seem to have this -
however I just did not pay any attention.
Hope this helps - I'll give you an update as soon as I have
further information.
Comment by Linus Nielsen Feltzing (linusnielsen) - Friday, 02 September 2005, 05:44 GMT

Does this still happen in the latest daily build?
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 13 September 2005, 05:55 GMT

As far as I can tell, this sounds like a hardware problem.
Perhaps your 100GB disk draws more power when spinning up?
Comment by Daniel (screenclene) - Wednesday, 09 November 2005, 12:07 GMT

I noticed this on my ondio too.
With an un-shuffled playlist with lots of files, it would after
playing say 20 smallish files without any problem, and then
repeat one file and skip another.
Since I listen to audiobooks this can be really annoying. I
solved the problem by merging the small files into larger files
(30 mins long) so that I rarely play more than 3 or 4 files in
any listening session.

I suggest that to reproduce this you create a playlist of 40
very short files (perhaps some one counting out loud?) and
see if they all play in sequence.

Comment by Daniel (screenclene) - Wednesday, 09 November 2005, 13:03 GMT

OK I can get very weird playlist behaviour as follows:

1. Create 40 short mp3 files of me speaking "1", "2", ..."40".
rec_0001.mp3 to rec_0040.mp3, in a sub directory

2. Create a playlist of those files in the right order in the root

3. Play the playlist.

The result:

It plays files 1 to 17
It plays file 3
it plays files 3 to 17
It plays file 3
it plays files 3 to 17
and keeps on in the same way until I stop it.

The subdirectory was called "all nums". The play list was
called "all numbers.m3u". I did this on and Ondio FM,
placing the files on the MMC card. The build num was CVS
Comment by Thomas Kobler (kobler) - Thursday, 17 November 2005, 06:54 GMT

Version 051105 of Rockbox seems to *not* repeat any songs in
a shuffled playlist anymore (on my 100GB/8MB cached disk
with about 15000 songs). If you provide a 8BM Recoder V1
Version of straight V2.5, I'll give it a try, too.

Thank you for fixing things by cleaning up and enhancing
Comment by Daniel (screenclene) - Thursday, 17 November 2005, 09:29 GMT

I just tested version 051117, and the problem I reported
isn't fixed, so clearly this is not he same bug you had
come accross. I'll mention this on the forums to see if
anyone can help.