FS#2543 - Fixes resume functionality retry

Attached to Project: Rockbox
Opened by Anonymous Submitter - Saturday, 25 June 2005, 21:07 GMT
Last edited by Hardeep Sidhu (hardeeps) - Wednesday, 29 June 2005, 17:16 GMT
Task Type Patches
Category Settings
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


this patch will correct a few things:

1. the playlist control file will be updated properly
when new files are added beyond the dirplay list.

2. the resume index setting is correctly updated for
all files. this is done in the playlist_next() function.

A secondary fix is located in playlist_viewer which
again calls playlist_next(0) to include the case of
users selecting a random song from the playlist viewer.
This task depends upon

Closed by  Hardeep Sidhu (hardeeps)
Wednesday, 29 June 2005, 17:16 GMT
Reason for closing:  Invalid
Comment by Anonymous Submitter - Saturday, 25 June 2005, 21:24 GMT


How can I reproduce the first problem you mention? We use
position instead of insert_position in the playlist control
file to preserve flags for sorting after resume. The
sorting stuff is minor and can be removed if it turns out
the be a problem but I'd like more information first.

Regarding 2 and your playlist viewer patch, this is a known
open issue on Rockbox: the resume values are only updated
from the WPS. I'm not sure your method is the best approach
as it only handles index, not offset. The playlist viewer
patch is incorrect, the playback code should be calling
playlist_next() at the start of play. If it doesn't then
there's a bug there that needs to be fixed.