FS#2549 - Tag Database Issues

Attached to Project: Rockbox
Opened by Anonymous Submitter - Monday, 27 June 2005, 21:15 GMT
Last edited by Daniel Stenberg (bagder) - Thursday, 07 July 2005, 11:09 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


First things first: I'm using Rockbox daily CVS-050627
on an FM Recorder.
HW info gives me this:
ROM: 1.23
Mask: 0x0304
USB: positive
PR: positive
Flash: M=BF D=D6
ROM CRC: 0x222F V1
ATA: 0x200, master

Okay, now to the actual bug.

I have used the and the (even
though the latter is useless on my FMR) present on the
Wiki along with a current build of ActiveState Perl for
Win32 to build the tag database. While building, it
gives me no errors whatsoever: it steps through the
directory structure in the music folder I've pointed it
to, reading each file and writing the data to the
database accordingly. No problems so far.

I then reboot my FMR, with the current daily build
flashed onto it. It reads the database correctly, as
far as I can tell, except for one problem: not all the
artists that should be listed are listed. Instead,
there are several entries at the bottom of the
'Artists' list that are listed as a single letter.
Within those entries are more single-letter album
entries, and within those are single-letter song
entries. This same error occurs in both the 'Albums'
list and the 'Songs' list.

I have had this same error since the TagDatabase page
went live on the Wiki. At that time, I was using the
perl.exe and perl58.dll listed on the page, but as the
current uses structs and such, the old
version of Perl will no longer work.

Any help would be much appreciated. Also sympathy from
others who have the same problem. Thanks for all the
help, devs.

-Matt Lichtenberg (wintermute)

This task depends upon

Closed by  Daniel Stenberg (bagder)
Thursday, 07 July 2005, 11:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  Logged In: YES

Ok, thanks for getting back on the subject. Closing this
report then!
Comment by Daniel Stenberg (bagder) - Thursday, 30 June 2005, 06:33 GMT

Can you identify one or more songs that cause this problem
and make it/them available for debugging?
Comment by Anonymous Submitter - Thursday, 07 July 2005, 06:29 GMT

I'm currently on dialup, but when I'm at work on Friday, I
will do so. Thanks for your help.

Comment by kerobaros (kerobaros) - Thursday, 07 July 2005, 07:42 GMT

Oh wow. I don't know if it was the new tagdb code that got
committed to the CVS, the new Java songdb maker that got put
on the Wiki, or my finally getting a SF account, but the tag
database now works perfectly on my FMR. My profuse thanks
to all of the devs responsible.

Comment by Daniel Stenberg (bagder) - Thursday, 07 July 2005, 11:09 GMT

Ok, thanks for getting back on the subject. Closing this
report then!