• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category FM Tuner
  • Assigned To No-one
  • Operating System Archos Recorder
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Version 3.1
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Rockbox
Opened by Anonymous Submitter - 2005-09-02
Last edited by GodEater - 2010-06-05

FS#2660 - No radio on FM recorder

The main menu doesn’t show the radio entry and
The “debug menu / HW info / FM Radio” page
shows “HW detected: No” on a FM recorder

Version CVS-050901

ROM: 1.23
Mask 0×0304 USB positive
PR: positive
Flash: M=BF D=D6 (I didn’t flash with Rockbox OS)
ROM CRC: 0x222F V1
ATA: 0×200, master

Closed by  GodEater
2010-06-05 22:34
Reason for closing:  Out of Date
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

If this is still an issue - we'll get it re-opened.

Anonymous Submitter commented on 2005-09-02 13:34

Logged by

mmohr commented on 2006-04-27 14:23

Does this bug still exist in newer CVS versions?
If nobody’s having this bug anymore and does report it here,
I’ll close this task in about a week from now on!

dbenz commented on 2007-07-03 19:06

Downloaded 2.2-2.4 and confirmed that the issue appeared between 2.1 and 2.2 apparently in the FM HW detection as 2.2 does not show the FM as detected in it’s separate menu. 2.1 does not appear to have a way to display the HW detect info, but FM works.

dbenz commented on 2008-03-13 18:46

Any update on this? I know it isn’t high priority, but was hoping it was just a HW detection/ID that fell out from 2.1 to 2.2 when that code changed.
Also just letting you know somebody is still out there hoping this gets fixed. :)

I recently had the FM radio disappear from my Sansa c250. Debug reported no hardware found. Eventually I thought to boot into the OF and the radio function worked fine there. When I booted back into RB the radio was detected and life is good again. Could this be the work in progress RB native USB connection is getting some radio bit twiddled?

I have a Sansa e260 that definitely still has this bug. Every version of RB I have tried on it does the same thing; “Debug > FM Radio > HW Detected: No”… Right after it was hooked to the USB cable, “FM Radio” will usually (not always) show up on the menu - but after a reboot or power cycle, it goes away for good. Radio works fine in the OF, although booting back into RB afterward does not restore the FM Radio menu option. Just updated it to v3.2, but there’s no change in the radio. It always works in the OF, so the radio is fully functional; RB simply can’t seem to find it. But this bug is definitely still present.

Sansa users may be looking for this bug: FS#7515


Available keyboard shortcuts


Task Details

Task Editing