FS#2915 - issues with volume control in FM radio - iriver h300

Attached to Project: Rockbox
Opened by Anonymous Submitter - Friday, 13 January 2006, 17:56 GMT
Last edited by Jonathan Gordon (jdgordon) - Wednesday, 22 February 2006, 23:27 GMT
Task Type Bugs
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


When I hold the volume down, the volume goes up slowly,
and when I release the button, the volume continues to
go up. I am assuming that this is just because the cpu
isn't handling the volume commands fast enough in FM
mode and the continued raising of the volume is the
system catching up with the input from the sustained
volume increase. This isn't a problem in regular music

When I raise the CPU as described before, this problem
is solved, but apparently at the cost of battery life.
Granted, I have a NT 2200mah battery rnning, but I am
still stingy with my battery life and anything to
conserve it is useful.
This task depends upon

Closed by  Daniel Stenberg (bagder)
Thursday, 23 February 2006, 11:32 GMT
Reason for closing:  Duplicate
Additional comments about closing:  duplicate of #2914
Comment by Jonathan Gordon (jdgordon) - Wednesday, 22 February 2006, 23:27 GMT

i have fixed this in my raio patch... but we are still
waiting for some1 to commit it..