Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Patches
  • Category Settings
  • Assigned To No-one
  • Operating System
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by tfact - 2006-02-05
Last edited by tfact - 2006-02-21

FS#2987 - Remote Select (All Working)

All Working Remote Select patch

Closed by  nls
2006-11-03 08:31
Reason for closing:  Out of Date
Additional comments about closing:  

Remote support with autodetection is in cvs

There’s a bug. On an H300 NON-LCD remote, the volume
buttons function as Up/Down, and don’t change volume.

Sorry, it does work. Ignore the previous followup.

nope… sorry. does NOT work on the H300 NON-LCD remote.
HOLD button is ON constantly… including bootup of course.

tfact commented on 2006-02-06 13:44

The judgment of hold button was loosened.

tfact commented on 2006-02-06 16:06

To boot it by remote control, Bootloader should be Bilded.

Anonymous Submitter commented on 2006-02-07 22:02

BY AIRWIN: H300 LCD trouble. Please fix these little things.
It’s almost perfect. Tanx a million.

[B]HOLD NAV[/B] get’s my player on :D WOEHOE!!!!

[U]In WPS[/U] (all ok except 1)
[B]HOLD NAV[/B] gets to playing menu as it should but it
goes there, goes back to wps and then goes there again to
stay there (in other works it blinks for a sec displaying
the wps). So it works, but it’s not working fine!!!

[U]After pressing NAV (file browsing)[/U]
[B]HOLD NAV[/B] gets you back 1 level in stead of going to
the filebrowser menu for playlist rename and delete dir … You have to hold play now to do this (NOT GOOD)
[B]HOLD PLAY[/B] functions as hold nav so gets you in menu
with playlist on top (NOT GOOD)

[B]HOLD LEFT or RIGHT[/B] goes back or up for only 1 level
but that is the same as on the player!!! Used to keep going
up or down until root or wps, but i’m fine with this :D.
[B]STOP[/B] goes back 1 level in stead of stop playing like
on the player

[U]While in a menu [/U]
[B]PLAY[/B] functions like nav button. Should do nothing
(not a problem for me!!!)
[B]LEFT[/B] When choosing an option. For example: Shuffle
yes or no (the highest level in the menu) it functions not
at all. When at the highest level i have to press STOP (so
it gets cancelled) to go down 1 level. After that i can use
the left button again. The rest of the menu (lower levels)
it works fine. (NOT GOOD)
There is a problem with the buttons when adjusting settings
like remote type, bass, etc. The up button is down, and the
other way arround and left and right don’t work.

Hold works fine as well.
REAAAAALLLLYYY an improvement. Now you can really say it
works (wich in this case means you can do everything you
want). Some minor adjustments would be awsome and make this
remote act axactly the same as the player itself.

Anonymous Submitter commented on 2006-02-08 12:01

Issue with H300 LCD remote: In Radio panel the left/right
and up/down buttons are reversed. So left/right controls
volume and up/down controls search. Hope this will be fixed…..

NON LCD remote has once again the HOLD problem…

tfact commented on 2006-02-09 14:16

Rework remote code now.
wait some days please

Anonymous Submitter commented on 2006-02-15 00:28

Any progress yet ?

tfact commented on 2006-02-18 00:23

new remote patch.
TEST version.

Returns the following error when compiling against current
CVS:

CC settings_menu.c
settings_menu.c:137: error: conflicting types
for ‘remote_type’ /home/guest/rockbox-bleeding/firmware/export/lcd-
remote.h:37: error: previous declaration of ‘remote_type’
was here
settings_menu.c:137: error: conflicting types
for ‘remote_type’ /home/guest/rockbox-bleeding/firmware/export/lcd-
remote.h:37: error: previous declaration of ‘remote_type’
was here
make[1]: * [/home/guest/rockbox-
bleeding/build/apps/settings_menu.o] Error 1
make:
* [all] Error 2

Actually, same error with the old patch…

tfact commented on 2006-02-19 21:52

V2.02 for Remote type autodetection

Anonymous Submitter commented on 2006-02-20 13:47

By: AIRWIN
Subject, just a reaaaally little improvement using the
H300lcd remote. It’s no good compared to the things that got
worse!!

Used optimized by needleboy 0.60 guess patch v2.0 and
there’s almost no change. All the problems still excist only
the:
There is a problem with the buttons when adjusting settings
like remote type, bass, etc. The up button is down, and the
other way arround.
That’s the only thing that’s improved.

Some things even got worse:
-Now left and right don’t function at all anymore in the
browser or menu.
- When i use my remote, my backlight of the player goes on
and not the light of the remote!!! Only when i press NAV the
remote lite goes on (and the players light stays of until i
press another button on the remote).
- and the excisiting problems:

[U]In WPS[/U] (all ok except 1)
[B]HOLD NAV[/B] gets to playing menu as it should but it
goes there, goes back to wps and then goes there again to
stay there (in other works it blinks for a sec displaying
the wps). So it works, but it’s not working fine!!!

[U]After pressing NAV (file browsing)[/U]
[B]HOLD NAV[/B] gets you back 1 level in stead of going to
the filebrowser menu for playlist rename and delete dir … You have to hold play now to do this (NOT GOOD)
[B]HOLD PLAY[/B] functions as hold nav so gets you in menu
with playlist on top (NOT GOOD)
[B]LEFT and RIGHT[/B] Don’t work
[B]HOLD LEFT or RIGHT[/B] does nothing!!! Even hangs my
player until i release. Used to keep going up or down until
root or wps, but i’m fine with this :D.
[B]STOP[/B] goes back 1 level in stead of stop playing like
on the player

[U]While in a menu [/U]
[B]PLAY[/B] functions like nav button. Should do nothing
(not a problem for me!!!)
[B]LEFT[/B] When choosing an option. For example: Shuffle
yes or no (the highest level in the menu) it functions not
at all. When at the highest level i have to press STOP (so
it gets cancelled) to go down 1 level. After that i can use
the left button again. The rest of the menu (lower levels)
it works fine. (NOT GOOD)
There is a problem with the buttons when adjusting settings
like remote type, bass, etc. The up button is down, and the
other way arround and left and right don’t work.

Anyways thanx for the try, keep up the good work and let’s
hope you get it working!!!

Anonymous Submitter commented on 2006-02-20 13:51

By: AIRWIN
Subject, just a reaaaally little improvement using the
H300lcd remote. It’s no good compared to the things that got
worse!!

Used optimized by needleboy 0.60 guess patch v2.0 and
there’s almost no change. All the problems still excist only
the:
There is a problem with the buttons when adjusting settings
like remote type, bass, etc. The up button is down, and the
other way arround.
That’s the only thing that’s improved.

Some things even got worse:
-Now left and right don’t function at all anymore in the
browser or menu.
- When i use my remote, my backlight of the player goes on
and not the light of the remote!!! Only when i press NAV the
remote lite goes on (and the players light stays of until i
press another button on the remote).
- and the excisiting problems:

[U]In WPS[/U] (all ok except 1)
[B]HOLD NAV[/B] gets to playing menu as it should but it
goes there, goes back to wps and then goes there again to
stay there (in other works it blinks for a sec displaying
the wps). So it works, but it’s not working fine!!!

[U]After pressing NAV (file browsing)[/U]
[B]HOLD NAV[/B] gets you back 1 level in stead of going to
the filebrowser menu for playlist rename and delete dir … You have to hold play now to do this (NOT GOOD)
[B]HOLD PLAY[/B] functions as hold nav so gets you in menu
with playlist on top (NOT GOOD)
[B]LEFT and RIGHT[/B] Don’t work
[B]HOLD LEFT or RIGHT[/B] does nothing!!! Even hangs my
player until i release. Used to keep going up or down until
root or wps.
[B]STOP[/B] goes back 1 level in stead of stop playing like
on the player

[U]While in a menu [/U]
[B]PLAY[/B] functions like nav button. Should do nothing
(not a problem for me!!!)
[B]LEFT[/B] When choosing an option. For example: Shuffle
yes or no (the highest level in the menu) it functions not
at all. When at the highest level i have to press STOP (so
it gets cancelled) to go down 1 level. After that i can use
the left button again. The rest of the menu (lower levels)
it works fine. (NOT GOOD)
There is a problem with the buttons when adjusting settings
like remote type, bass, etc. The up button is down, and the
other way arround and left and right don’t work.

Anyways thanx for the try, keep up the good work and let’s
hope you get it working!!!

tfact commented on 2006-02-20 19:19

Thank you!
Bug fix now.

There were changes in CVS for button.c
That causes patching errors now.

tfact commented on 2006-02-21 15:40

It’s fix now.
Please wait a little.

takka commented on 2006-02-27 01:18

V2.05 for CVS

Takka, I think this patch causes the PLAY button on the H300 player (also on the NON-LCD remote) not to function in the browser and and menus.
Can you check it please?
Try my source and my build as an example.

takka commented on 2006-02-28 16:59

Thank you.
Fix now.

Any progress maybe?

tfact commented on 2006-03-05 00:13

v2.06 fix tree mode

Excellent work Takka! Maybe this will soon be ready for CVS?

H300 NON-LCD Remote works perfectly.
H100 LCD Remote works perfectly.

Haven’t had any reactions about the H300 LCD Remote yet. I’ll post here as soon as I know anything.

Thanks again, man!

tfact commented on 2006-03-05 22:57

V2.07 for CVS 5 Mar 22:29

tfact commented on 2006-03-18 10:28

v2.11
playlist tree bug fix
add some remote settings

I got a report about a problem when using FF/RW on the non-lcd remote the player freezes which then requires a reset.

cpu commented on 2006-03-19 21:45

And on non-lcd remonte “HOLD switch ON…” - still appears when I want to power on my H320

Latest changes to CVS (as far as buttons.h and buttons.c go) break the patch.. as far as I can see beyond manual patching..

tfact commented on 2006-03-21 19:35

In which mode do it become such a situation?

When will the FF/RW freezing bug be fixed? Hopefully as soon as possible!

tfact commented on 2006-03-29 08:41

for cvs 29 Mar 07:57

cpu commented on 2006-03-30 19:14

@takka:
Can you give changelog for this relase ?
Thanks for this patch and your work !

Bug with he H3x0 LCD remote : once I’ve changed the volume with the remote, no key work anymore (on remote and main unit). The only thing I can do is stop my H320.

The problem occurs after pressing ffwd / rwd while playing music, and not volume.

The H300 LCD remote support was perfect before the auto-detection feature was introduced. Can’t you roll back to a manual remote type setting ?

tfact commented on 2006-06-24 01:54

for CVS 23 Jun 14:14 apps/eq_menu.c 1.18

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing