FS#2995 - Lost all controls after renaming song

Attached to Project: Rockbox
Opened by David Bowden (dbowden) - Tuesday, 07 February 2006, 17:10 GMT
Last edited by Daniel Stenberg (bagder) - Monday, 10 April 2006, 08:57 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Immediate
Reported Version Release 2.5
Due in Version Version 3.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Running Rockbox release v2.5, not flashed, on a Jukebox
Studio 20.

I had resume on, and shutdown using the Stop button, as
is my normal practice. I transferred some new files,
(via USB), and also renamed a number of files,
including the song which had been playing when I shut
down (yes, it was a dumb thing to do). When I turned
the player back on, I did not see the normal startup
screens (no "Jukebox ver: 5.06", no "Rockbox"). The
song which was playing last did resume playing, but
there was no title displayed (the battery, volume,
Play icon, and "Audio" icon were displayed). I could
stop the tune currently playing, but had no other
controls. Menu would display a "Param" icon but had no
other effect, On would cause the current track to play
if it was stopped, Play would cause the current track
to play if it was stopped, Stop would stop the current
track if playing, or turn off the player if held down,
+ and - had no effect.

I powered the player up and down several times, and
eventually reinstalled Rockbox to solve the issue.

Jukebox Studio 20 flashed with Jukebox v 5.06, running
Rockbox v2.5
From debug menu(HW Info):
Rom 5.03
USB: neg
ATA: 0x300m
Mask: 0000
This task depends upon

Closed by  Daniel Stenberg (bagder)
Thursday, 27 April 2006, 13:05 GMT
Reason for closing:  Out of Date
Additional comments about closing:  No response
Comment by Stephan Lutz (XMoDX) - Thursday, 23 March 2006, 08:37 GMT
I had the same problem with a bleeding egde build from 22th of March 2006 (I can't really remember which one) for the iriver h120.
The problem seems to be, that the log file for the currently playing playlist is looking for the last played song at startup. When this song is not at his place anymore (by removing or renaming it), the rockbox booting process crashes.
Comment by Peter D'Hoye (petur) - Sunday, 09 April 2006, 22:51 GMT
Can you please give a detailed procedure how to reproduce this issue?
I have tried the following with resume enabled:
- normal playback
- dynamic playlist
- saved playlist

unable to get it to crash. Maybe a recent change fixed this? Can you try again?
Comment by Daniel Stenberg (bagder) - Monday, 10 April 2006, 09:02 GMT
It would also be very interesting if you could try a recent daily build and see if the problem is there too. 2.5 is very old by now...